Jump to content

Detroit Become Human ultrawide & multimonitor mod 0.9.9


12 Screenshots

About This File

The tool removes black bars from the game at 21:9, 32:9, 48:9 and other wide resolutions.

  1. Download and unpack the archive using software like 7zip or PeaZip. The password is pcgw
  2. Launch the game
  3. Launch the tool
  4. Press the "Enable" key
  5. While in the game, briefly switch to the Borderless or Fullscreen mode.
  6. Use the tool to manually adjust the UI size at 32:9 and wider resolutions.

Known issues:

  • Stretched loading screens and rare FMVs.
  • Minor UI display and alignment issues. Use the UI adjustment keys if necessary.

The window mode switching requirement is also undesirable, hence the version number!
Tested the latest Epic version at 2560x1080, briefly at 3840x1080, 5760x1080, 5120x2160 and 7680x1080 on a single monitor.

You can buy me a coffee here.


What's New in Version 0.9   See changelog

Released

No changelog available for this version.




User Feedback

Recommended Comments



12 minutes ago, Alex said:

Many thanks! Is it possible to do hex mod to avoid launching tool everytime?

Based on the current findings, it wouldn't be reliable. I know Quantic Dream haven't been updating Heavy Rain and Beyond at all but I don't want to make anyone depend on me. The trainer is less likely to be affected by game updates

Share this comment


Link to comment
Share on other sites
2 minutes ago, Rose said:

Based on the current findings, it wouldn't be reliable. I know Quantic Dream haven't been updating Heavy Rain and Beyond at all but I don't want to make anyone depend on me. The trainer is less likely to be affected by game updates

The fix does not work for me... 3440x1440. I fun the fix as admin, run the game, click f9, click f5, make the game to run borderless, but the blackbars still exist

Share this comment


Link to comment
Share on other sites

Tried all the combinations of keys... nothing helps. Launch the game - wait loading screens, when menu appears, I alt-tab the game, turn on the fix, alt-tab game, click F9, click F5, double alt-enter and nothing happens.

Share this comment


Link to comment
Share on other sites
3 minutes ago, EGOISTE said:

Tried all the combinations of keys... nothing helps. Launch the game - wait loading screens, when menu appears, I alt-tab the game, turn on the fix, alt-tab game, click F9, click F5, double alt-enter and nothing happens.

The current version works on my end. I'm also updating the trainer to better support 3440x1440 resolutions, though it will not help if you are getting 16:9 image pillarboxed as opposed to 2560x1080 slightly pillarboxed.

Do you have the latest EGS version of the game, not the demo used to run it illegally?

3440.png

Share this comment


Link to comment
Share on other sites
36 minutes ago, Rose said:

Based on the current findings, it wouldn't be reliable. I know Quantic Dream haven't been updating Heavy Rain and Beyond at all but I don't want to make anyone depend on me. The trainer is less likely to be affected by game updates

Maybe you could post the hex values for this version and leave it just for information.

Anyway big thanks.

Share this comment


Link to comment
Share on other sites
2 minutes ago, Rose said:

The current version works on my end. I'm also updating the trainer to better support 3440x1440 resolutions, though it will not help if you are getting 16:9 image pillarboxed as opposed to 2560x1080 slightly pillarboxed.

Do you have the latest EGS version of the game, not the demo used to run it illegally?

3440.png

Yes, of course I have bought the game...

image.thumb.png.8e5299ac102801a0ce768ecc99ce108b.png

Share this comment


Link to comment
Share on other sites
Just now, Alex said:

Maybe you could post the hex values for this version and leave it just for information.

Anyway big thanks.

The trainer injects new code, so it is not limited to replacing bytes.

Share this comment


Link to comment
Share on other sites
7 minutes ago, Rose said:

The current version works on my end. I'm also updating the trainer to better support 3440x1440 resolutions, though it will not help if you are getting 16:9 image pillarboxed as opposed to 2560x1080 slightly pillarboxed.

Do you have the latest EGS version of the game, not the demo used to run it illegally?

3440.png

Yes, you were right, 0.9.5 trainer does not help...

Share this comment


Link to comment
Share on other sites

All I can think of is anti-virus software getting in the way. I doubt freesync would have any effect on the game refreshing its state after a display mode change.

Share this comment


Link to comment
Share on other sites
Just now, Rose said:

All I can think of is anti-virus software getting in the way. I doubt freesync would have any effect on the game refreshing its state after a display mode change.

All what I have is windows defender... Are you running the game on Windows 10? 

Share this comment


Link to comment
Share on other sites

When I press F6, the title "F6 3440x1440" becomes green, but if I put F9, its title do not becomes green, but I don't know whether it says something or not

Share this comment


Link to comment
Share on other sites

Enable/disable should become and stay green indeed. The rest of the text briefly turning green sadly isn't indicative of anything. I would try disabling Defender, though it is up to you!

Share this comment


Link to comment
Share on other sites

it must stay green? in my case, it's become green only for 3-4 seconds. I'm gonna try to verify game cache and turn off the windows defender.

Share this comment


Link to comment
Share on other sites

Well, sorry for your time. I accidiently turned off the f9 key on my razer blackwidow keyboard. Sorry for the wasting your time. And thanks for your work!

Share this comment


Link to comment
Share on other sites
45 minutes ago, EGOISTE said:

I accidiently turned off the f9 key on my razer blackwidow keyboard. Sorry for the wasting your time. And thanks for your work!

Glad you got it working and thank you @Rose for all your hard work supporting this mod!

Share this comment


Link to comment
Share on other sites

The first time I used the ultrawide tool (2560x1080) the game looked fine, but now it looks zoomed in (vert-) everytime I try it. What did I do wrong?

Share this comment


Link to comment
Share on other sites
10 hours ago, Vuze said:

Thank you very much! May I kindly request you to add support for 5120x2160? Cheers!

I think that was supported out of the box?

Regardless, after 4 more hours on the mod, I made it that it now adapts to the current screen or window size, regardless of what it is.

I also added keys for custom UI adjustment.

2ar.png

Share this comment


Link to comment
Share on other sites

Thank you for fixing the UI! I can't stress out how important that was for this game, you are the best Rose! Also thanks for the RDR2 fix, what would the UW Community do without you?

Version 0.9.9 looking great after a short test at 3440x1440 

Share this comment


Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
  • Found PCGamingWiki useful? Please consider making a Donation or visiting our Patreon.
  • Similar Content

    • By Rose
      The small patcher removes the resolution limit introduced in update 1.17.

      After patching, the list of resolutions available for selection will remain limited to the hardcoded 16:9 and 16:10 resolutions, but selecting any 16:9 resolution above native will now set the game to that monitor resolution.
      Unpack the archive and patch the file as instructed Launch the game and select any or the highest resolution above that of your monitor (for example, choosing 2560x1440 at 2560x1080 will have the game set to 2560x1080 without displaying it) Disregard the numbers and back out into the main menu to see that the image properly fills the screen width. Tested the latest Epic version at 2560x1080. Check out my black bars remover for the game as well.

      You can buy me a coffee here.
    • By Rose
      The patcher allows to select 21:9 and wider resolutions in the game
      Patch the game file as instructed by the tool. Launch the game and select your resolution in the settings to avoid stretching.
      (sometimes the resolution may be listed under 16:9) Tested the latest Steam version briefly at 2560x1080 and 3840x1080.
      You can buy me a coffee here.
    • By ShadowStealer7
      These patches are made using the addresses posted by Reddit user OnkelJupp to remove ultra-widescreen pillarboxing from Horizon Zero Dawn without the need for manual hex editing.
       Unpack the archive using the password pcgw Open the desired patcher and navigate to the game folder where HorizonZeroDawn.exe is located and click Start Launch the game and set the aspect ratio in the settings to Auto Included resolutions are 2560x1080, 3440x1440, 3840x1600, 5120x2160, 6880x2880 and a combined patcher for 32:9 aspect ratio resolutions 3840x1080 and 5120x1440.
      Tested on the launch Steam version.
  • Who's Online   0 Members, 0 Anonymous, 234 Guests (See full list)

    There are no registered users currently online

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Member Statistics

    5,662
    Total Members
    3,870
    Most Online
    camm
    Newest Member
    camm
    Joined
×
×
  • Create New...