Jump to content

1 Screenshot

About This File

Features:

Removes the pillarboxing (black bars) which appear on ultrawide monitors

Installation:

  • Unpack the archive
  • Copy all files into two game folders
  1. "\FINAL FANTASY XIII\"
  2. "\FINAL FANTASY XIII\white_data\prog\win\bin\"

Hotkeys:

F5 - FOV +
F6 - FOV -
F7 - Default FOV

 

In the Settings.ini file, you can change the following settings 

[RESOLUTION]
Fullscreen = 0

forces full-screen mode

Width = 0
Height = 0

forces the screen resolution

[FOV_MAIN]
Additional_degrees = 0.000

FOV value in degrees that will be added to current FOV;
doesn't affect to battles and cutscenes

[FOV_BATTLE]
Multiplier = 1.000

multiplier for FOV value used in battles

[FOV_CUTSCENE]
Multiplier = 1.000

multiplier for FOV value used in cutscenes





User Feedback

Recommended Comments

This patch is awesome. Do you think it would be possible to apply a similar patch to Final Fantasy XIII-2 and Lightning Returns ?

Share this comment


Link to comment
Share on other sites

Thank you for the patch, it's been only 5 years, well worth replaying the game. Hope for XIII-2 patch as well, I like it much more!

Share this comment


Link to comment
Share on other sites

thank you so much for this fix! i also hope for XIII-2 and lightning returns patch as well. you are a life saver! and pls pls also patch the other 2 games thank you so much!

Share this comment


Link to comment
Share on other sites

Hi. Followed directions as exactly. Do I need to install any other programs along with the ultrawide fix? The black pillarboxed bars are still present. Thanks! [I use a 2560 x 1080p ultrawide monitor maybe that's why it will not work?]

*Update* Tried it on my roommate's pc and they use a 3440 x 1440p ultrawide monitor and it worked perfectly. 

 

Share this comment


Link to comment
Share on other sites

Hello! I'm unable to get this patch to work. I have placed the contents from the zip file in both of the mentioned game folders. I also have edited the settings.ini with my desired resolution (5120x1440), and I was unable to get any result. The first time I had opened the game with this patch, it crashed on the title screen before showing the game's logo. The second time opening, the patch had no effect. Please let me know if there is anything I am doing wrong. Thanks!

Share this comment


Link to comment
Share on other sites

On 3/20/2021 at 10:37 PM, justin_shoe said:

Hi. Followed directions as exactly. Do I need to install any other programs along with the ultrawide fix? The black pillarboxed bars are still present. Thanks! [I use a 2560 x 1080p ultrawide monitor maybe that's why it will not work?]

*Update* Tried it on my roommate's pc and they use a 3440 x 1440p ultrawide monitor and it worked perfectly. 

 

2560x1080 resolution is definitely not the reason why it doesn't work. It works fine for me.

Maybe there is some problem with the loader.

Try this version with a different loader - ffXIIIASI.zip

  • Unpack the archive
  • Copy all files into two game folders
  1. "\FINAL FANTASY XIII\"
  2. "\FINAL FANTASY XIII\white_data\prog\win\bin\"
  • Set the resolution in both files
  1. "\FINAL FANTASY XIII\Settings.ini"
  2. "\FINAL FANTASY XIII\white_data\prog\win\bin\Settings.ini"

ffiii.jpg

Share this comment


Link to comment
Share on other sites

 

7 hours ago, killer-m said:

2560x1080 resolution is definitely not the reason why it doesn't work. It works fine for me.

Maybe there is some problem with the loader.

Try this version with a different loader - ffXIIIASI.zip

  • Unpack the archive
  • Copy all files into two game folders
  1. "\FINAL FANTASY XIII\"
  2. "\FINAL FANTASY XIII\white_data\prog\win\bin\"
  • Set the resolution in both files
  1. "\FINAL FANTASY XIII\Settings.ini"
  2. "\FINAL FANTASY XIII\white_data\prog\win\bin\Settings.ini"

ffiii.jpg

Hi thanks for the feedback!

Unfortunately it didn't work for me. Here's what I attempted at.

- Copied and pasted both in:

  1. "\FINAL FANTASY XIII\"
  2. "\FINAL FANTASY XIII\white_data\prog\win\bin\"

Result: No success

 

- Left files but changed resolution to width = 2560 and height = 1080

Result: No success

 

- Changed Fullscreen = 1 -> Fullscreen = 0 *w/ width and height untouched*

Result: No success

 

- Unplugged multi monitor and attempted just the ultrawide monitor

Result No Success

 

Possibility:

- I do have my game on my "D" drive while Steam is on my "C" drive. I might have to try changing it to all on "D" drive later to see if it works. 

If there's anything else that might be helpful I definitely appreciate it so much! Thanks for taking the time out of your day to troubleshoot with me @killer-m

Share this comment


Link to comment
Share on other sites

Hey all,

just created an account to tell @justin_shoe that I had the exact same problem with the fix not working.

For me the only way I could make it work was to deinstall the reshade mod. It was this mod here: https://www.nexusmods.com/finalfantasy13/mods/22?tab=files Both are overwriting the game.exe and the reshade stuff seems to be dominant and deactiving the ultrawide fix. Maybe that's the issue for you as well.

@killer-m Do you see a way to fix this issue? Anyway thanks for this fix. It really is awesome!

 

Share this comment


Link to comment
Share on other sites

8 minutes ago, fredkonkret said:

Hey all,

just created an account to tell @justin_shoe that I had the exact same problem with the fix not working.

For me the only way I could make it work was to deinstall the reshade mod. Both are overwriting the game.exe and the reshade stuff seems to be dominant and deactiving the ultrawide fix. Maybe that's the issue for you as well.

@killer-m Do you see a way to fix this issue? Anyway thanks for this fix. It really is awesome!

 

One point I tried the patch by itself but it still didn't work for me. *This was before the alternative file btw* only thing I can think of which I haven't got around to yet was installing the game on the same drive as my operating system. This could solve it but yeah. when I get to it I'll post my update here as to whether that method works or not.

Share this comment


Link to comment
Share on other sites

On 3/25/2021 at 9:50 PM, justin_shoe said:

 

If there's anything else that might be helpful I definitely appreciate it so much! 

Try hardcoded 2560x1080 - ffxiiiHC.rar password - pcgw

Copy ffxiiiimg.exe to "\FINAL FANTASY XIII\white_data\prog\win\bin\"

Hotkeys and Settings.ini are not available in this case.

To get a custom resolution, you need to change the bytes at these offsets

22E3568 00 0A 00 00
22E356C 38 04 00 00

Share this comment


Link to comment
Share on other sites

7 hours ago, killer-m said:

Try hardcoded 2560x1080 - ffxiiiHC.rar password - pcgw

Copy ffxiiiimg.exe to "\FINAL FANTASY XIII\white_data\prog\win\bin\"

Hotkeys and Settings.ini are not available in this case.

To get a custom resolution, you need to change the bytes at these offsets

22E3568 00 0A 00 00
22E356C 38 04 00 00

@killer-m Thank you so much! I'm happy to update you and anyone else who comes across this that your fix worked! Not promoting, but just wanted to share my test gameplay with it on for the first couple minutes of the game. Thank you so much for taking your time and you've made another FFXiii player happy in the community 🙂 !

 

Share this comment


Link to comment
Share on other sites

The only thing that works for me is the Hardcoded. Only thing is it mandatory fullscreen. So if you playing within a 16:9 monitor you have to actually set  windows to 2560x1080.

Share this comment


Link to comment
Share on other sites

Thanks so much for this, looks amazing. Would kill/pay to see the same for the other two games if possible.
Any idea what to set the FOV value to for 21:9? I'm no good with this stuff. Thanks again.

Share this comment


Link to comment
Share on other sites

Hello,

thank you for the mod. I want to play the game with my beautiful widescreen but I have an issue. The game is stuck at Square Enix logo and freeze. I've tried to edit the settings.ini and use the hardcoded but it didn't work. I don't use Reshade (except for FFXIV) and I suspect Nvidia Geforce Experience to create a conflict between the game and the mod. Is there anyone that can help me?

EDIT : it worked with the hardcoded exe, but I have some strange graphic glitches, mostly shadow and some UI

Share this comment


Link to comment
Share on other sites

Hi! This mod was working for me for about 2 weeks and out of nowhere one night it stopped working. I tried everything down to deleting the entire game and redownload it, but nothing works. Could any exterior file affect this mod? Do I need to set up something on FFXIII fix to make this works? 

Anyway I would use the hard coded version because this one works but I can't find what value I should use for my 3440x1440 resolution. So I'm stuck on a 1080p resolution which is ew.

So could you give us a tutorial on what HEXES should we put to get our desired resolution?

Share this comment


Link to comment
Share on other sites

Please help! This mod just will not work for me, I set my settings to fullscreen 3440 x 1440 and it seems as if the settings file does nothing as the game completely ignores it and just does whatever the launcher is set to. I uninstalled all the other mods I have and nothing is making this work. I downloaded the 21:9 1080P launcher that you shared with some one in this thread but I have a 1440P monitor and I really want to play at 1440 rather than 1080. Any help would be appreciated, thank you.

Edit: NEVERMIND PLEASE IGNORE ME I AM JUST DUMB! 
I got it figured out I just had the files in the wrong spots, thanks for the mod really appreciate it!

Share this comment


Link to comment
Share on other sites

Made an account just to thank you ^^

So thank you very much killer-m !!!

(If you ever have the spare time and kindness, pls consider doing a fix for its ssequel FFXIII-2)

Share this comment


Link to comment
Share on other sites

Anybody got this to work on Gamepass?

Tried both standard method and hardcoded method. Standard method doesn't do anything it seems, hardcoded seems to crash on launch.

Of course I put one set of files in the "Content" folder since that is essentially the name of the root folder for most Xbox installs. The bin folder was in its normal spot nested down from there

Share this comment


Link to comment
Share on other sites

Thanks @killer-m, works for me (mostly) on a 24:10, 3840x1600 screen.

BTW, is it correct that the effects in combat (like red flashing while low hp) are still 16:9 or am I missing some settings?

Also, what do the three FOV settings (FOV_MAIN, FOV_BATTLE, FOV_CUTSCENE) do exactly? What value do they multiply? From my short tests changing the value for FOV_MAIN didn't do anything. I haven't compared the other two settings yet.

For a while, using the Hotkeys to change would crash my game, but now it works again, so I don't know if something's going on here or not. Is it possible to save the setting of whatever you've changed it to or do you need to do it everytime you start the game?

Share this comment


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Add a comment...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...