Jump to content

PCGamingWiki will use a Single Sign On (SSO) system to bridge wiki and forum accounts which is ready for testing. You may login using the 'Login with PCGamingWiki' button on both the wiki and the forum, which will soon be the only option. If you have any issues please message Andytizer on Discord.

TheFreeman

Dragon Age 2 - Wrong processor and VRAM detection

Recommended Posts

*system specs at the end of the topic*

 

I recently got Dragon Age 2 for the PC, retail version, updated it to 1.04 and installed the Hi-Res Texture Pack (the official one, directly from BioWare). No problem with the settings, enabled everything, put rendering quality to DX11 and enabled all the extra features in the game menu (so not the configuration.exe program) like Ambiental Occlusion ecc.

 

However, when going to System Detection in the config.exe, i noticed two very odd things. Firt, the VRAM of my video card (a 2GB GDDR5 Nvidia GTX 750ti from Asus, OC model) is detected as an infinite, negative number (something like -238478549...) and the number of cores of my processor (an AMD FX-8320 with 3,5ghz and 8 cores, Black Edition) also is wrong. Instead of 8 cores and 8 threads, it is detected as 1 core and 1 thread!

 

So you may say "well, if you have the game still running smooth as butter, what's the problem?" that's because the games is not as smooth as butter, and i get and average of 40FPS with drops to 25 and max of 60. So yeah, not a bad frame rate, but a friend of mine, who has an AMD Athlon X2 3.2ghz and an Nvidia GTX560 with 1GB GDDR5 gets steady-rock 60fps even with lots and lots of units on screen, everything maxed and hi-res patch on.  Is there a solution to this? 

 

Here my PC specs:

 

CPU: AMD FX-8320 Black (8 cores, 8 threads, 3,5ghz)

GPU: Nvidia GTX750ti (Asus OC; 2GB GDDR5; latest drivers installed)

RAM: 8GB DDR3 from Kingston (HyperXBlu with 1600mhz clock)

 

Share this post


Link to post
Share on other sites

Delete your configuration settings, I don't know the exact path, probably here %USERPROFILE%\Documents\BioWare\Dragon Age 2\

 

Backup the whole folder just in case before messing with it. Can you have your settings be auto-detected? I'm wondering if that could help with anything. Maybe the game didn't install properly.

 

Bear in mind I am just trying to take a guess as to what might help. You could try playing in a Windowed mode and see if the performance is improved.

Share this post


Link to post
Share on other sites

Looks like it's not a problem with the config.exe file, but with the game itself. Apparently the game is able of running at smooth-60fps only with Radeon Cards and the Nvidia GTX 560. It's a driver related problem, and that is the only Nvidia card capable of running the game correctly. Fine, i still get a decent fps rate, but having more would've been much better.

Share this post


Link to post
Share on other sites

Do you get better results in DirectX 9 mode?

Yes. But Hi-Res textures are almost invisible in that mode and there is no Ambiental Occlusion. It's not that big of a problem, the frame rate is still pretty good (around 35-40fps with rare drops to 20) but it's a shame i can't get the 60fps i deserve, since my system is perfectly capable of that.

Share this post


Link to post
Share on other sites

Texture really shouldn't behave differently with other rendering paths..

 

Anyway, make sure you are not running weird overlays, you are using latest chipset/audio/graphics drivers and BIOS.

 

Then plenties of times stupid AV software or stupid codec packs can really mess up a computer..

 

Anyway, if this still doesn't change anything, check MSI afterburner overlay to monitor the game when it's stuttering. You'll be able to clearly notice whetever CPU/GPU is being heavily stressed.

Also, take note both DA:O and DA2 uses Physx... which is really prone to problems

Share this post


Link to post
Share on other sites

I use K-Lite and used to use CCC, they're very common.

Did you mean CCCP? (cause Catalyst Control Center is another thing)

In fairness, I never really documented about it. And darn, according to wikipedia is really neat. LAV filters, xy-VSFilter and MPC-HC. Personally I wouldn't know anything better (madVR aside)

 

But k-lite (which I admit I used to use) is burdensome to monstrous levels. You don't just have a codec for every thing. But sometimes even 2 or 3 different ones for format.

Not to mention, I always wondered how they could legally include mainconcept dlls and other stuff not-so-redistributable (or free)

Share this post


Link to post
Share on other sites

Sorry yeah I meant CCCP. I've flipped and flopped between K-Lite and CCCP and never really had significant problems with either.

 

You could get away without installing codecs by using applications like VLC, XBMC and Plex server. But I like using Media Player Classic myself.

Share this post


Link to post
Share on other sites

But I like using Media Player Classic myself.

Me too.

But since they started to come bundled with LAV filters... I believe nobody with noob to advanced needs should require anything else.

 

Perhaps enthusiasts with particular needs for outlandish formats still require more

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Who's Online   0 Members, 0 Anonymous, 90 Guests (See full list)

    There are no registered users currently online

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Forum Statistics

    1,179
    Total Topics
    6,654
    Total Posts
×