Jump to content

PCGamingWiki will use a Single Sign On (SSO) system to bridge wiki and forum accounts which is ready for testing. You may login using the 'Login with PCGamingWiki' button on both the wiki and the forum, which will soon be the only option. If you have any issues please message Andytizer on Discord.

Soopytwist

Splinter Cell: Pandora Tomorrow

Recommended Posts

I really don't know why I'm even bothering to try and play old games because so far they're all f'ked.

 

I've managed to set the game to run at 2560 x 1440 with a FoV suitable for 16:9 but there are two problems.

 

1. The cutscenes crash the game with either this message:

 

General protection fault!

History: UGameEngine::GameFlowEndMap <- UGameEngine::Exec <- UPlayer::Exec <- UViewport::Exec <- UWindowsViewport::Exec <- APlayerController::execConsoleCommand <- UObject::ProcessEvent <- (GUIController Transient.InteractionMaster0.GUIController0, Function GUI.GUIController.SendConsoleCommand) <- UObject::execDelegateFunction <- (GUIController Transient.InteractionMaster0.GUIController0 @ Function GUI.GUIController.OpenMenu : 0103) <- AActor::ProcessState <- Object EchelonMainHUD 0_0_1_Handcuff.EchelonMainHUD1, Old State State EchelonHUD.EchelonMainHUD.s_Mission, New State State EchelonHUD.EchelonMainHUD.s_Mission <- AActor::Tick <- TickAllActors <- ULevel::Tick <- TickLevel <- UGameEngine::Tick <- UpdateWorld <- MainLoop

 

Or this one:

 

General protection fault!

History: UGameEngine::Init <- InitEngine

 

But the game itself seems to work - though I haven't got a clue what's going on because I can't watch any of the cutscenes.

 

The second problem is some weird lighting issue where moving the mouse about changes certain textures from dark to light or they flicker.

 

Any ideas what to do?

 

EDIT

 

Oh and the mouse cursor in the menus is floaty and totally out of control.

Share this post


Link to post
Share on other sites

First question: does it crashes without widescreen/fov fixes?

Second question: is your game patched to latest version?

Third question: I spent an entire freaking afternoon on the wiki article trying to remember the steps I did that remote time when I had it running quite well.. Is it ok for you?

 

Fourth question: damn, we already replied to both your past problems.. and I can say fairly sure that star trek elite force troubles are not windows 7/game specific. Files checksums mismatch = files are not the same of the working version = you have a corrupted installation. This could be due to some unlucky, rare cd reads.. or due to an actual damage to the game CD

Elite force 2 issue on the other hand, got some replies you never bothered to answer..

Share this post


Link to post
Share on other sites

I didn't reply to them because I gave up. I actually threw the Elite Force discs away with the full intention of fishing them out again and putting the game away but I forgot and now they're in landfill!

So that's the end of that. Maybe the discs were corrupt, perhaps buying the game again from eBay I'll have a working copy but the discs will be the same age and possibly just as corrupt. It certainly wasn't an install issue because I re-installed in onto my C drive (Samsung SSD) and the same problem occurred and I didn't get around to installing it under a virtual XP mode - and now I can't anyway. Elite Force 2's issue cannot be fixed, I've hunted everywhere for an ID Tech engine FoV fix and cannot find any and Flawless Widescreen doesn't have a fix either.

 

As for this, Splinter Cell Pandora Tomorrow, I'll give it ago without the widescreen hack and see what that does...

 

EDIT

 

Re-installed, tried running it without any configuring of settings or hacks and is still crashes in the first cutscene and again in the second if the first is skipped. Still got the flashing textures in the game too (and because I've got a 2560 x 1440 monitor three inch black borders left and right). Then I re-installed it again this time on my SSD, keeping the recommended C drive install directory, same problem...except for the fact that it installs and loads quicker obviously.

 

The thing is the installer twice tells me my graphics card is too old (oh the irony!).

 

Specs:

 

Intel i7 3970X
16Gb Corsair Vengeance 1600
Asus P9X79 Deluxe
2x EVGA GeForce GTX 780 SC ACX (in SLI) - drivers 335.23
Windows 7 Ultimate (64bit)

 

The only thing I got out of that little experiment was the unnecessary slightly reduced lifespan of my SSD.

Share this post


Link to post
Share on other sites

The thing unacceptable for me, it's not the lack of answers, but the fact itself that you have given up. ;)

However, if cd is screwed, reinstalling the game wouldn't be very helpful, and another cd doesn't have to be necessarily broken like the last..

 

Back on topic anyway, did you actually patched the game?

Share this post


Link to post
Share on other sites

Yes I patched it. The game is part of the four title Revival edition (Splinter Cell, Splinter Cell: Pandora Tomorrow, Chaos Theory and Double Agent). I submitted a support ticket to Ubisoft and they effectively said they don't support Pandora Tomorrow any more. Fair enough, it is a decade old but then they suggested updating graphics card drivers and DirectX....as if that would make a difference to a 10 year old game! Anyway I already did that, I do it regularly anyway though there's probably a new driver since 335.23 but really, that's more likely to make the situation worse.

 

They also suggested XP compatibility mode which I already tried and told them so in my original email.

Share this post


Link to post
Share on other sites

Weird.

Well, I own the game. But the problem is that.. it's somewhere in the house.. :$

Anyway, the cutscenes is meant to be a FMV or in-game?

 

If is the first case.. try disabling desktop composition, themes and all the other stuff here

Running as administrator is certainly mandatory, since the game saves in the program files folder

 

Then, if this is still not working try this

Share this post


Link to post
Share on other sites

Yeah I tried disabling visual themes, desktop composition etc - didn't seem to make a difference and I shouldn't need to run as admin because I disabled UAC when I first had Windows 7, but I still ticked it in the compatibility settings for the games shortcut anyway.

 

The cutscenes are all FMV, .bik files. Although they're in the install directory they are also on the disc and the disc has to kept in the drive to run - I'm wondering if it's running the videos from the disc and falling over. Hmm, further experimentation required.

 

The funny thing is , I'm now having problems playing Double Agent (I skipped Chaos Theory because it's not that long ago I replayed it - and it was fine). The issues with Double Agent however would appear to be a bad console port.

 

EDIT

 

Well they're not being read from the disc because I renamed all the .bik files (to.fuk) and that skips all the cutscenes. If I was to play the game without them I'd have to play them on my iPad or something to watch them - otherwise I won't know what's going on. That just leaves the weird texture problems which is no-doubt down to the two 780's that the game assumes are older than it.

Share this post


Link to post
Share on other sites

I have double agent installed on my PC right now (thanks god I have it on steam, damn cds)! I would be honored to follow up your neverending troubles :3

 

Btw, the videos are bik as I thought.. if I were you I would give a try to that directshow filter manager and use it to Restore standard DirectX codecs

do you use ffdshow maybe?

Share this post


Link to post
Share on other sites

Yes, I have the K-Lite codecs installed. I made this just now: http://youtu.be/GalccgnUopk

 

Oh and I had the idea of disabling SLI but then realised to my horror that it was already disabled after a recent driver update, I did wonder why Goat Simulator was running like a pig (or goat?) when all hell was breaking loose, now I know why!

 

Anyway I turned it back on and Pandora Tomorrow is the same.

Share this post


Link to post
Share on other sites

DirectShow Filter Manager reports several ffdshow codecs, if I disable them can I get them back again using this tool or do I have to reinstall the K-Lite pack?

Share this post


Link to post
Share on other sites

Yes, I have the K-Lite codecs installed. I made this just now: http://youtu.be/GalccgnUopk

 

good lord.

Scrape k-lite codecs immediately! [1] [2]

They have fucked up so many friends' computers.. They are nonsense compilations of cracked, higgledy-piggledy pointless codecs...

Just use VLC if you are lazy, or install LAV filters & MPC if you want a more professional feel

 

No wonder your biks have issues.. Trust me, uninstall it and reset directshow configuration

Share this post


Link to post
Share on other sites

Well shit...looks like it was the k-lite pack causing the problem just like you said. I've not bothered to install VLC yet though, wanted to test the game out first - maybe even finally play the damn thing before doing so too.

 

Even without k-lite I still seem to be able to play .f4v in WMP, although .flv currently plays with no video. I guess I don't need to play .flv right now and I make videos in the .f4v format now anyway so I'll leave VLC for another day.

 

Okay, that sorts out the crashing, now what about the texture issues as shown in my Youtube vid?

Share this post


Link to post
Share on other sites

The lighting issue, is a well known one instead.. Unfortunately it's a driver issue.. newer GPUs don't support old lighting instructions..

Try to check this. There are many possible solutions.. Scrape omega drivers though

 

And WMP is known to not support flv

Share this post


Link to post
Share on other sites

None of that made a difference just like the OP of that thread - and I'm not going to bother changing drivers either, bugger that.

 

I've tweaked nearly everything in the ini's one-by-one from true to false and vice versa and checking each change - nada.

 

Guess I'm not going to fix this...aside from actually building a retro PC out of the crap I've still got hanging around in the loft. There's always virtual XP but that's a lot of taffing about. I'm just going to play it like it is and make do, unless it starts crashing again and then I'm afraid it's in the bin with Elite Force for poor old Sam Fisher.

Share this post


Link to post
Share on other sites

If it would start again to crash.. it would have its reasons.. like the broken codecs before..

 

anyway, I hope I could find the time to test this (such as 3d analyze settings)soon.. even though I won't probably be able to look at the problem until the summer..

This problem should be caused by a bad xbox port btw

 

Nice luck with the rest

 

ps: and oh, please, post your fix in the end of your ubisoft forums thread.. or link this discussion maybe.. so that future users could manage to solve too

Share this post


Link to post
Share on other sites

Yeah this is pretty much impossible to play. Sam looks like he's in dark shadow but the light meter is all the way up and he's spotted immediately. Not only are the there no shadow casting but light sources are not rendering properly either making most attempts at stealth nigh on impossible or at the very least extremely difficult - rather unfortunate for a stealth game, uh?. Reading that section of the wiki on the Windows port from the Xbox it looks like only old Nvidia cards from 6 onwards (and certainly not two GTX 780's!!) are not supported and this was never patched. The Tom Clancy wiki does mention these can be forced on - doesn't say how to do that and the PC Gaming wiki doesn't say anything about it either - that's kinda' odd for this site claiming to fix PC gaming. Strange that Splinter Cell 1 being the oldest runs better than Pandora Tomorrow.

 

Time to give this up. Thanks for all your help Mirh but this is where I get off.

Share this post


Link to post
Share on other sites

Certainly the game is going to be a shit without shadowing..

And after some technical searches i can say that it's not only a problem with you, but with everybody that isn't using a Geforce 3/4/5 series (the older series of course, which as of today is about 99% of people). Good damned xbox (which is geforce 4 based)

 

splinter cell 1 can run better since it still has a fallback mode... which seems to be not available in SC:PT

And of course, we would be pleased to have the fix. But it has to exist before d:

 

see you soon

Share this post


Link to post
Share on other sites

Couldn't you just make a summary of the relevant stuff, no one is going to bother looking through 7 pages of that.

I would bother

Share this post


Link to post
Share on other sites

Couldn't you just make a summary of the relevant stuff, no one is going to bother looking through 7 pages of that.

 

Here's a summary of that thread:

 

The initial conversation was finding drivers which would allow older GPUs compatible with the game to run on modern systems and lacked any change to DirectX 8.x handling which would bug out Pandora Tomorrow's lighting, especially relevant for NVIDIA users. (Mirh listed several sources for compatible drivers.) Eventually, a user going by the name Komat did some assembly and DX debug output deep-dives on the game and came up with a special wrapper, still very much a work-in-progress, designed to override the obsoleted DX8 behavior with modern equivalents. The remaining pages of the thread mostly consist of users testing out the wrapper and reporting their results, along with Komat's responses.

Share this post


Link to post
Share on other sites

Here's a summary of that thread:

 

The initial conversation was finding drivers which would allow older GPUs compatible with the game to run on modern systems and lacked any change to DirectX 8.x handling which would bug out Pandora Tomorrow's lighting, especially relevant for NVIDIA users. (Mirh listed several sources for compatible drivers.) Eventually, a user going by the name Komat did some assembly and DX debug output deep-dives on the game and came up with a special wrapper, still very much a work-in-progress, designed to override the obsoleted DX8 behavior with modern equivalents. The remaining pages of the thread mostly consist of users testing out the wrapper and reporting their results, along with Komat's responses.

Tanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Who's Online   2 Members, 0 Anonymous, 59 Guests (See full list)

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Forum Statistics

    1,200
    Total Topics
    6,739
    Total Posts
×