Jump to content

Welcome to the upgraded PCGamingWiki forums and files page. The current Wiki and Forum bridge is not functioning at the moment, therefore your Forum account currently has no password set. Please reset your Forum password via email check to generate a new password. If you have any issues please message Andytizer on Discord.

Vorob

Flickering in old games on Nvidia (very strange problem)

Recommended Posts

Hello, I’ve got a very strange issue with several old games, and I'm trying to find a solution. I'll do my best to describe my issue.

I’m sitting on laptop, Lenovo Y580, packed with i7 quad core cpu and Nvidia Optimus system (intel hd 4000 + nvidia 660m). It’s all working on Windows 7 x64 (SP1 + All updates). All drivers are fresh and Nvidia driver is 332.21.

My problem is that in some old games (direct x 6 and 7 era) 2d elements flicker horribly, i'm talking about interface, menus and so on. 3d is ok. And that’s all only on Nvidia.

I saw this problem in several different games:

Rainbow Six (1998)
No One Lives Forever (2000)
Blood 2 (1998)
Gabriel Knight 3 (1999)

I've got a friend with the same laptop, the only different thing is that he has Windows 8 installed, no flickering. Same driver for nvidia.
I also have another friend with Nvidia Optimus laptop from another vendor and he is on Windows 7, he has flickering.
Aaaand i also found this guy in the interent with the same exact problem:https://forums.geforce.com/default/topic/626974/pc-components/630m-flickering-2d-elements-and-fmvs/

So, i’m trying to understand what unites games mentioned above? (directx 6-7 i suppose?)
And what has changed in Windows 8, so flickering is gone? 

p.s. I was able to launch NOLF and Blood 2 in window mode, flickering was gone, other games don’t have windowed mode. 

p.s. i’m Russian, sorry for my English.

Share this post


Link to post
Share on other sites

With Optimus you can set which GPU a game uses; I don't have an Optimus system to refer to so I don't know exactly where this option is, but that would be a thing to try since the other GPU might have a different result.

 

Windows 8 makes changes to rendering; among other things the 8- and 16-bit color modes are now virtualised; this incidentally fixes certain display issues seen on XP/Vista/7, so some games are actually more compatible because of this.

Share this post


Link to post
Share on other sites

Have you tried forcing the games in a window via DxWn, or setting your screen to run in 16bit colors:

http://forums.steampowered.com/forums/showthread.php?t=965494

http://forums.steampowered.com/forums/archive/index.php/t-2219928.html

 

No i didn't i'm trying to solve this issue without windowed mode cause it sucks :( And NOLF is 32bit game, well it looks like 32 in options.

 

 

With Optimus you can set which GPU a game uses; I don't have an Optimus system to refer to so I don't know exactly where this option is, but that would be a thing to try since the other GPU might have a different result.

 

Windows 8 makes changes to rendering; among other things the 8- and 16-bit color modes are now virtualised; this incidentally fixes certain display issues seen on XP/Vista/7, so some games are actually more compatible because of this.

 

Ye on Intel it works ok, but i'm interested in nvidia :)

 

Thx for info about windows 8!

 

 

This sounds oddly similar to what I've experienced testing Gorky 17... having AMD Radeon 7770HD. No flickering in Windowed mode, but with flickering when using fullscreen.

 

check your pm please :)

Share this post


Link to post
Share on other sites

No i didn't i'm trying to solve this issue without windowed mode cause it sucks :( And NOLF is 32bit game, well it looks like 32 in options.

 

I don't know what you don't like in windowed mode but if it is window borders you can disable them by using GameCompanion or similar software. As a result you would get a fake fullscreen. I don't think it is an issue only related with Windows itself, also a renderer problem as well. From personal experience I know that especially DirectDraw games have several issues on modern operating systems. For some games there are 3rd party modifications or patches that allows them to run in modern systems. (e.g. Fallout, Planescape: Torment etc.)

 

I don't know which versions of those games you use but I also suggest you to use GOG.com version whenever possible. Three of those games except NOLF is already available on GOG.com. What makes GOG special is their versions are modified to run on modern operating systems.

Share this post


Link to post
Share on other sites

Ye, i'm using gog.com versions. Since i've got a friend with same laptop but on w8 and all is ok, i think its smth in my system that brakes the game. I'm trying to find it. 

Share this post


Link to post
Share on other sites

I don't know what you don't like in windowed mode but if it is window borders you can disable them by using GameCompanion or similar software. As a result you would get a fake fullscreen. I don't think it is an issue only related with Windows itself, also a renderer problem as well. From personal experience I know that especially DirectDraw games have several issues on modern operating systems. For some games there are 3rd party modifications or patches that allows them to run in modern systems. (e.g. Fallout, Planescape: Torment etc.)

Yes, DirectDraw games are starting to cause plenty of problems on modern machines. This is why, I'm hoping DXGL project is going to solve such problems in the future. Anyway, about the subject.

The assumption there may be something about DirectX 6 and 7 could have been right, except - as far as I know, No One Lives Forever is actually using DirectX 8.1 (which reminds me, I should do something about that page). GameCompanion (and other Borderless Fullscreen application) is actually a good idea as long as it's possible to run the game at a proper resolution.

 

-- EDIT --

OK, nevermind. The game actually installs DirectX 7.

Share this post


Link to post
Share on other sites

I saw different directdraw wrapper around the net while i was trying to fix Atlantis - the lost tales

Try this or this..

 

And it seems here they mention problems with nvidia graphics card too

Share this post


Link to post
Share on other sites

I saw different directdraw wrapper around the net while i was trying to fix Atlantis - the lost tales

Try this or this..

 

And it seems here they mention problems with nvidia graphics card too

 

http://bitpatch.com/ddwrapper.html

 

This thing made Rainbow Six not to flicker, but game crashes when 3d is loading...

 

We are on the right way i suppose? Its DirectDraw issue? Maybe little bit strange question, but what happened from 2000 to nowdays that DX 6-7 not working properly? And what about DX 8?

Share this post


Link to post
Share on other sites

If game crash, try customizing the configuration file

 

btw it seems an issue with windows 7 nvidia drivers.. but i'm not sure.. 

maybe nvidia inspector could made the trick?

Share this post


Link to post
Share on other sites

For DX8 games there is also a DX8 to DX9 convertor by Boris Vorontsov.

 

We are on the right way i suppose? Its DirectDraw issue? Maybe little bit strange question, but what happened from 2000 to nowdays that DX 6-7 not working properly? And what about DX 8?

DirectDraw has been deprecated since DirectX 7. It is an old 2D API and this is why developers do not support it anymore, instead they use D3D for 2D rendering, which is more efficient. I do not know much about technical details but as the time goes current APIs get constantly updated and old ones don't. So some API parameters gets outdated therefore current hardware does not understand these parameters, then the user gets graphical anomalies such as flickering, missing textures, ghosting etc.

 

For instance about a few days ago I tested Return to Mysterious Island which is a DDraw game. There was no flickering but game/rendering speed was way too fast. I tried several wrappers, compatibility modes but had no luck.

Share this post


Link to post
Share on other sites

http://bitpatch.com/ddwrapper.html

 

This thing made Rainbow Six not to flicker, but game crashes when 3d is loading...

 

We are on the right way i suppose? Its DirectDraw issue? Maybe little bit strange question, but what happened from 2000 to nowdays that DX 6-7 not working properly? And what about DX 8?

 

I was wrong, this thing forced RS to work in software mode, and that's why it wasn't flickering. So ddwrapper didn't help me at all, we are back at the begining :) 

Share this post


Link to post
Share on other sites

So my conclusion is that this is a problem with nvidia drivers.. Try installing the oldest available ones, then if this still doens't work try something middle between oldest and newest

 

@JPulowski 

Microsoft should still support older directx version. At most they software emulate legacy functions. This seems more like a bug in the nvidia drivers to me (it works well when software emulated and when ran on the intel igp). Older directx version support frequently become bugged when graphics card vendor update their driver, since nobody still test deprecated API

 

For your problem, it's obvious that compatibility settings doesn't work. You are getting too many fps and that's the problem. You had to limit them

as stated before, I had a hard time with Atlantis: The Lost Tales. And this is how i was able to do so with that game

Share this post


Link to post
Share on other sites

For your problem, it's obvious that compatibility settings doesn't work. You are getting too many fps and that's the problem. You had to limit them

as stated before, I had a hard time with Atlantis: The Lost Tales. And this is how i was able to do so with that game

Tried it, but unfortunately did not work. I also tried limiting frame rate via NVIDIA Inspector and it did not help either. And I don't think it is directly related with NVIDIA because the game has a software/hardware rendering option. And both options have the same issue. Also tried slowing down the game via Cheat Engine, and yes it did not help as well. But thanks for your help though.

Share this post


Link to post
Share on other sites

But.. it's a 2004 game! I thought it was way older.

Anyway there's even another method to limit framerate

Here it seems they have fixed the problem

 

Will give a try to as soon as GOG.com staff grant us the game to test it

Share this post


Link to post
Share on other sites

Just a quick note, i've installed Win 8 and i can confirm that old games work perfectly there, no flickering. 

Did you still have access to win 7?

It would be a nice thing to track down what dlls are creating the problem

Share this post


Link to post
Share on other sites

But.. it's a 2004 game! I thought it was way older.

Anyway there's even another method to limit framerate

Here it seems they have fixed the problem

 

Will give a try to as soon as GOG.com staff grant us the game to test it

Limiting frame-rate won't work. All methods works the same way. The issue is related with in-game clock, the processing speed is very fast. I also took a look at Process Explorer, but couldn't understand exactly which method that user used. Tried Cheat Engine for slowing down the in-game clock. It is not perfect, it just makes everything laggy. I guess GOG.com needs to take a look at it.

Share this post


Link to post
Share on other sites

Did you still have access to win 7?

It would be a nice thing to track down what dlls are creating the problem

 

Yes i have. How can i do this?

Share this post


Link to post
Share on other sites

Download processmonitor and run it. Exclude all others annoying programs

Open the game and when you double click its entries in PM, you'll see a list of loaded .dlls with their relative path

 

Copy .dlls used by the game from the corresponding one in the Windows 8 partition to the game folder until you find the one which creates the problem

Share this post


Link to post
Share on other sites

You case is different, its simple v-sync bug. Force vsync in drivers. If you are on optimus, force your game to work on nvidia.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Who's Online   1 Member, 0 Anonymous, 61 Guests (See full list)

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Forum Statistics

    1,135
    Total Topics
    6,525
    Total Posts
×