Jump to content

Welcome to the upgraded PCGamingWiki forums and files page. The current Wiki and Forum bridge is not functioning at the moment, therefore your Forum account currently has no password set. Please reset your Forum password via email check to generate a new password. If you have any issues please message Andytizer on Discord.

Kelmer

How to mirror my desktop to my TV

Recommended Posts

First of all sorry if this is not the proper place to ask...

 

I have an ATI Radeon HD 6900 and a LG 42LN570S Smart TV. My computer is in one room, my TV is in the room next to it. I want to be able to play my Steam games in my TV, so I bought a 12 meter HDMI cable. I connected it but I am able to see either my computer image in my TV or in my monitor. I cannot mirror my desktop or expand it to use both screens at the same time, it says it's unsupported My Monitor is connected through the DVI port (my graphics card has two of these). Could the problem be caused by my using of the HDMI instead of two DVI cables? Is it a matter of drivers?

 

Also to my understanding HDMI carries both image and audio but I would think the output of my graphics card obviously is only carrying video info, I guess this is a stupid question and I have pretty much answered myself but is there any way to send audio info through the hdmi port as well?

Share this post


Link to post
Share on other sites

I think you need a special HDMI driver, on an Nvidia card that's installed automaticaly with the Geforce experience thingy, I never really got my TV's audio to properly work on my AMD card, I used my pc speakers instead.

 

The AMD website is down so I can't really check which driver you might need.

 

If you are on Windows 8 try pushing Win plus P, it brings up this menu, dunno if it might help

sWfn7um.png

 

Your TV is probably not being properly detected by windows or maybe it's probably going out of range, somehow. This is what it looks like for me anyway.

lQAGsvn.png

 

 

Edit: Oh right sorry, you said that it's unsupported on those modes, I honestly don't remember if there's any HDMI related drivers other than the audio one. 

 

You could always try using a DVI to VGA converter and see if it helps. Also from what I've read you might have to fiddle around in your BIOS? I don't remember having any monitor related options on my BIOS.

Share this post


Link to post
Share on other sites

For the audio to work, just right click on the volume icon on the bottom right of your screen, press playback devices and make sure HDMI is the default audio device.

 

For screen mirroring just check what ratchet said. Or play with eyefinity settings if you want more customization (in the Catalyst Control Center)

Share this post


Link to post
Share on other sites

Thanks, I finally got it working! Turns out I was connecting my TV to one HDMI output and my monitor to the other DVI output instead of the output corresponding with the HDMI one. As for the sound, I got it working but it seems I cannot have both audio outputs at the same time, is that right?

Share this post


Link to post
Share on other sites

As for the sound, I got it working but it seems I cannot have both audio outputs at the same time, is that right?

There's pretty simple workaround for this actually. 

Put your regular speakers as default output device. Next from input right click and enable disabled devices. If you have correct drivers and sound card from this century you should see Stereo Mix. Enable it, go to preferences, from listen tab tick "listen to this device" and select your TV output. Make sure to put levels to 100 on other tab. 

 

Screenshot, sorry for non-english: 

Z4Ddxt2.png

Share this post


Link to post
Share on other sites

There's pretty simple workaround for this actually. 

Put your regular speakers as default output device. Next from input right click and enable disabled devices. If you have correct drivers and sound card from this century you should see Stereo Mix. Enable it, go to preferences, from listen tab tick "listen to this device" and select your TV output. Make sure to put levels to 100 on other tab. 

 

Screenshot, sorry for non-english: 

Z4Ddxt2.png

 

There's pretty simple workaround for this actually. 

Put your regular speakers as default output device. Next from input right click and enable disabled devices. If you have correct drivers and sound card from this century you should see Stereo Mix. Enable it, go to preferences, from listen tab tick "listen to this device" and select your TV output. Make sure to put levels to 100 on other tab. 

 

Screenshot, sorry for non-english: 

Z4Ddxt2.png

This is what i have tho with the proper drivers

scpjAmG.png

Share this post


Link to post
Share on other sites

There's pretty simple workaround for this actually. 

Put your regular speakers as default output device. Next from input right click and enable disabled devices. If you have correct drivers and sound card from this century you should see Stereo Mix. Enable it, go to preferences, from listen tab tick "listen to this device" and select your TV output. Make sure to put levels to 100 on other tab. 

 

Screenshot, sorry for non-english: 

Z4Ddxt2.png

Awesome!! thanks for the detailed instructions, it's working like a charm now :)

Share this post


Link to post
Share on other sites

This is what i have tho with the proper drivers

scpjAmG.png

That's output tab, you can only select one default output device from there (because windows lol). What I was saying you should make Stereo Mix from input tab to output sound to another device. 

 

EDIT: Panasonic-TV. Best plasma TV for gaming :)

Share this post


Link to post
Share on other sites

Oh well, at least it works

Oops sorry I missed your earlier post! I had the same mistake, I was looking for it on the output tab, just as Marioysikax said, it's on the input tab.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Who's Online   1 Member, 0 Anonymous, 107 Guests (See full list)

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Forum Statistics

    1,072
    Total Topics
    6,324
    Total Posts
×