Jump to content

Welcome to the upgraded PCGamingWiki forums and files page. The current Wiki and Forum bridge is not functioning at the moment, therefore your Forum account currently has no password set. Please reset your Forum password via email check to generate a new password. If you have any issues please message Andytizer on Discord.

  • 0
HerbertWest

Heavy Metal Fakk2 suddenly stops working on WIN10 64

Question

Very weird problem with this old game. Used to run perfectly fine with maxed out settings incl. widescreen patch 1920x1080 on my Asus X551ca, Intel HD 4000, i3-3217U 2core @1,80 ghz., Realtek HD audio.

Recently tried to continue playing after a long break and the game is suddenly unplaybable. Starting it, I get to the game menu / settings, but the short logo video isn't played (Just get black screen till the menu and music starts).

When I try to begin the game, it freezes at the "ankh"-like loading screen before intro is played or any savegame can be loaded.

 

I tried to reinstall it several times, to any partition, and played around with setting the folder to (access-unrestricted) "root" of my c or d drives, any Program files & games folder etc., but no luck.

 

I reinstalled all drivers for graphics and audio hardware, using Driver Talent to get all the latest versions, again, no luck.

 

I thought about the Creators update, although i noticed the error before getting the huge package, there were some Windows updates before. But installing Creators Update from the get go in a VMWare machine just revealed the game seems to run just fine with it. (Still, it is not impossible the newest Intel HD or Realtek drivers don't work with this game and my specific hardware + Creators update). I thought about the copy protection maybe messing with some new driver or registry setting and installed a NoCD which runs perfectly fine in my virtual machine, but it doesn't change anything. Damn!

 

Does anyone have a clue what this could be about and how I could fix this? I looked for similar complaints in the internet, but all I found were some "grey screen" problems with ancient graphic cards from around 2000-2004. Usually, the people reporting couldn't play the games with their hardware right from the start. About all other windows games on my laptop continue to run perfectly well.

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Bumped, because I couldn't figure this out up to today. I tried all kinds of Glide and DirectX Wrappers, but the problem just remains the same.

 

 

 

The "Ritual" logo video at the very beginning never gets played before the menu, and all tries to start the game from the menu onwards will freeze up at the loading screen.

 

Could this be due to current Intel Drivers or some video codec problem? As said, it runs fine in a virtual WIN10 machine via VMWare.

Share this post


Link to post
Share on other sites
  • 0

I think the game uses OpenGL for rendering and DirectX is just for input, so graphics wrappers wont work. But don't quote me on that.

 

Did you try renaming fakk2.exe to quake3.exe ?

Share this post


Link to post
Share on other sites
  • 0

I don't know what to suggest, I played the game recently with no issues, but on Windows 7. Did you try using any compatibility settings like turning off desktop composition, visual themes, display scaling and that kind of stuff ? Did you try disabling DVR ?

Share this post


Link to post
Share on other sites
  • 0

Yes, by now I checked all compatibility modes. Nothing of that really changes anything.

 

As I said, it worked like a charm on my WIn10 system without any need for these settings just some months ago.

But I still tried every compatibility setting out in trial & error by now. It's really weird. The problem must be a reaction to some change in my system (drivers, codecs, other programs etc.) I don't know anything about.

 

 

DVR, is that about the xbox app on win10? I never used this, but I'll try soon if disabling helps in any form.

EDIT: Disabled game bar in win 10 settings, but no change.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Forum Statistics

    942
    Total Topics
    6078
    Total Posts
  • Who's Online   0 Members, 0 Anonymous, 44 Guests (See full list)

    There are no registered users currently online



×