Jump to content


Photo

I was useful today


  • Please log in to reply
11 replies to this topic

#1 ImprovizoR

ImprovizoR


  • Posts: 4

Posted 16 December 2015 - 03:20 PM

I don't really know where to put this topic so may as well be here. I just uploaded a fix that makes The Godfather 1 run at 60 fps. It's my first time doing something like this. I'm not a programmer so don't ask me to do the same with other games. I just like messing with things from time to time and I wanted to replay this game without getting a headache.

 

Here it is: http://community.pcgamingwiki.com/files/file/660-the-godfather-60fps

 

It seems to be working OK but I've only just started a playthrough. I guess it's time to update the page description for this game :D


  • Nicereddy, Blackbird and Mars icecream like this

#2 Blackbird

Blackbird


  • Posts: 240

Posted 16 December 2015 - 06:22 PM

If it works without any serious glitches then good job! I really liked the game.



#3 RaTcHeT302

RaTcHeT302

Posted 17 December 2015 - 06:15 AM

Is the first God Father game similar to the PS2 version? I never knew it was on PC. Also the file hasn't been approved yet.



#4 TerminatorOST

TerminatorOST


  • Posts: 25

Posted 17 December 2015 - 12:51 PM

Thanks, I will try to play it today and will reply if there are glitches or not.

Update: Well, I've played about ten missions and didn't see anything unusual. Thanks again for the fix. Now I have a good reason to replay the game.



#5 ImprovizoR

ImprovizoR


  • Posts: 4

Posted 18 December 2015 - 05:38 PM

I'm glad it's working alright.

 

Is the first God Father game similar to the PS2 version? I never knew it was on PC. Also the file hasn't been approved yet.

It's widely considered to be a very bad port with a terrible control scheme but it's so much fun regardless. You can get used to the controls or you can use a controller. 30fps lock bothered me the most.



#6 Mars icecream

Mars icecream


  • Posts: 198

Posted 19 December 2015 - 10:10 PM

​Excellent work! 30 FPS was the reason why I haven't played the game on PC.

Is the frame rate capped to 60 after applying the fix or can I run the game above 60 FPS?



#7 ImprovizoR

ImprovizoR


  • Posts: 4

Posted 20 December 2015 - 11:47 AM

It's capped.



#8 Mars icecream

Mars icecream


  • Posts: 198

Posted 17 January 2016 - 10:05 AM

-



#9 Mars icecream

Mars icecream


  • Posts: 198

Posted 13 April 2016 - 09:49 PM

​I tried to start the game on Windows 10 64-bit, crashes instantly. Does the game work for you? I've tried with and without your exe.

Glad to see that someone has found a fix: http://pcgamingwiki.com/wiki/Godfather#Game_crashes_after_copyright_screen_on_modern_Windows_versions

​Does "FMVs" mean all cutscenes? If "extra clips" are those short movie clips in the menu, I don't really care.



#10 Mars icecream

Mars icecream


  • Posts: 198

Posted 13 April 2016 - 10:22 PM

In-engine cutscenes play. I used a registry tweak to run the game in 1920 x 1080 resolution, 16:9 resolutions aren't listed: http://www.wsgf.org/dr/godfather

​Unlimited FPS fix on WSGF completely breaks the game - the FOV is incredible high and some areas aren't rendered, the game is running several times faster and there's audio delay.

3dqgt7K.jpg



#11 Mars icecream

Mars icecream


  • Posts: 198

Posted 01 October 2016 - 09:06 AM

I apologize for claiming the tweak doesn't work, I was extremely disappointed with the WSGF fix (above). I tried rating 5 stars, accidentally hit 1 star and the ratings can't be changed :(
I created a 30/60fps comparison, I don't see any major issues. Sorry about stuttering, I was saving to external hard drive.

 

30fps: https://gfycat.com/UnpleasantOilyHalicore

60fps: https://gfycat.com/RecentMeagerBlacklemur


  • Blackbird likes this

#12 Doler

Doler


  • Posts: 1

Posted 30 December 2016 - 04:15 AM

the reason why I haven't played the game on PC






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users