Jump to content
Sign in to follow this  
TheRR

Losing internet connection when launching steam games

Recommended Posts

 

Elevator, has a problem regarding steam & internet. The problem is that when I open some games that are right now (h1z1, pubg and Rainbow six siege) I lose connection from the internet. If I have Teamspeak / discord or stream then they are publishing also I have to re-open those apps. Doesn't happen with cod black ops as I play a lot for a reason, just the games mentioned in "()"

For example: If I start H1Z1 then it will be black on both screens for 0.5-1 second also I will be disconnected from almost everything. The only app that is not disconnected is Google chrome.

Started with Rainbow six siege, didn't think much of it, but when it started happening with other games, that's when I got frustrated.

Has 150/150 

Specs:

Motherboard - ASUS ROG Strix B360-F Gaming

CPU - Intel Core i7-8700 GPU - MSI GTX 1060 6GB

PSU - Corsair RM850x, 850W

Cooling - Corsair Hydro H150i PRO

RAM - G.Skill Trident Z DDR4 16GB

M.2 SSD - Samsung 970 EVO 1TB

ThePC is 1 year old, so not an old PC. Have checked everywhere for information or help, Youtube, Google, Reddit, but don't seem to know what the problem is or what is causing it. Tried to change the games on another hard drive it did not work. Re-installing the games did not work. Deleting the entire steam and everything with steam on the PC did not work. Now I am really considering restarting my entire PC.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

  • Found PCGamingWiki useful? Please consider making a Donation or visiting our Patreon.
  • Who's Online   2 Members, 0 Anonymous, 279 Guests (See full list)

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Forum Statistics

    1,409
    Total Topics
    7,621
    Total Posts
×
×
  • Create New...