Jump to content

Welcome to the upgraded PCGamingWiki forums and files page. The current Wiki and Forum bridge is not functioning at the moment, therefore your Forum account currently has no password set. Please reset your Forum password via email check to generate a new password. If you have any issues please message Andytizer on Discord.

Ladderman

Monopoly Tycoon problem

Recommended Posts

Hi

I have just managed to get Monopoly Tycoon working on my Windows 10 PC(this was because of the game didn't like the music on when starting,and i had to Manually install the Windows Media Source Filter).

I Installed Monopoly Tycoon from my CD,and then installed the 1.4 patch,and altered the config file to 1920x1080 in game screen resolution.

Everything seemed to be working fine,until i worked through the Tutorials.In particular "Creating a Shopping Centre".Halfway through this Tutorial it asks you to build a business on one of the blocks.I click on the build button and then i can only see the button Activate building rights.When i hover the pointer over the button Activate building rights it doesn't highlight,like all the other buttons would do.After that i am stuck,and have to go to the title screen.

If i use Patch 1.3 i don't get this problem,but i don't get as many custom scenarios.On Patch 1.3 when you click on the build button(in the Creating a Shopping Centre Tutorial),it automatically lets you build a business.

I don't know if this is a Windows 10 problem,i can't remember having this problem on my previous Windows versions whilst playing this game.

Acn anybody suggest as what i can try to fix this problem?.

Thanks for looking

Colin

My PC Specs

Windows 10 Home 64 Bit
Gigabyte Z370 AORUS Ultra Gaming: ATX, LG1151, USB 3.1, SATA 6GBs
Intel Core i7 Six Core Processor i7-8700k (3.7GHz) 12MB Cache
Super Quiet Titan DragonFly Heatpipe Intel CPU Cooler
1TB SEAGATE FIRECUDA 3.5" SSHD
6TB WD BLACK 3.5" WD6001FZWX, SATA 6 Gb/s, 128MB CACHE (7200rpm)
CORSAIR 650W TXm SERIES SEMI-MODULAR 80 PLUS GOLD, ULTRA QUIET
8GB AMD RADEON™ RX 580 - HDMI, 3 x DP - DX 12
8GB AMD RADEON™ RX 580 - HDMI, 3 x DP - DX 12
Creative Sound Blaster Zx 5.1 PCI-E Soundcard
32GB Corsair VENGEANCE DDR4 3000MHz (2 x 16GB)
24x DUAL LAYER DVD WRITER ±R/±RW/RAM
AOC G2770PF HDMI LCD 27 inch Monitor

Share this post


Link to post
Share on other sites

What you came across seems like a bug in version 1.4. Version 1.3 was the last official patch for the game. I have the exact same issue here!

There could be many causes of the problem. The scenario seems completely broken with the building rights. A possible solution could be to get the specific tutorial level scenario file from version 1.3 and replace the 1.4 version, if the 1.4 patch does create a new one even in the first place. I have tried in software mode and still won't work. It completely locks up the game which is really surprising.

The Windows Media Source Filter was dropped instantly when Windows Vista started development (even when it was still longhorn). Very few games utilize it at all, Ford Racing 2 and Test Drive 6 are the only games besides Monopoly that have been discovered to use it extensively.

I am really glad that so many people could utilize the fix I made for the game's music! If you want to make the music not skip around (stutter) remove the qasf.dll in C:\Windows\SysWow64\ and it will fix the stuttering even on Windows XP (possibly even Windows 2000). Please note that the qasf.dll is required for plenty of legacy games to render intro movies.

NOTE: There is an automatic installer (.bat file) that automates the codec installation of the WMA Source Filter, you don't have to do it manually.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Who's Online   0 Members, 0 Anonymous, 104 Guests (See full list)

    There are no registered users currently online

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Forum Statistics

    1,136
    Total Topics
    6,532
    Total Posts
×