Jump to content

mrpenguinb

Member
  • Content Count

    38
  • Joined

  • Last visited

  • Days Won

    1

mrpenguinb last won the day on November 24 2020

mrpenguinb had the most liked content!

About mrpenguinb

  • Rank
    Member

Contact Methods

  • Website
    https://mcdebugrndmstuff.blogspot.com/

Recent Profile Visitors

1,301 profile views
  1. 1. Go to "Display" settings in the Windows 10 Settings app, scroll-down and go to "Graphics settings". 2. Under "Choose an app to set preference", select "Desktop app" and click "Browse". 3. Browse to where Mega Man Legends is located, select the "MEGAMAN.EXE" exectuable and click "Add". 4. The game will have been added to the list in the Windows 10 Settings app. 5. Click "Options". Make sure to select "High performance GPU: NVIDIA GeForce 940MX". 6. Run the game. Let me know if you have any issues and if it works.
  2. What are your laptops specifications? Such as CPU, Graphics Cards/Chips, RAM. The issue with being unable to run the game on your laptop is probably being caused by the alien GPU's that it has, as Mega Man Legends wasn't designed to run on laptops. That isn't even considering how many slight differences in laptop hardware and specification there are compared to a desktop. dgVoodoo2 should fix the graphical issues on your laptop, as it reinterprets everything that the game will try to do, acting as a blanket/buffer.
  3. Are the graphics working properly now? If the graphics display properly, extract dgVoodoo again, making sure that all the .dll's and stuff are copied (shown in attached screenshot). After re-installing dgVoodoo, right-click MEGAMAN.EXE, go to Properties, then Compatibility and tick "Run in 640x480 screen resolution", Apply and close. (remember to revert this later!) Copying what cloudhaacker said, "Open up dgVoodoo and on the DirectX tab check Disable & Passthrough to real DirectX. We have to turn it off temporarily to change the renderer. Start the game, and once it starts try
  4. Make sure you have set your display resolution to 800x600 when trying to run the game. Personally I would unplug all monitors except one to keep things simple.
  5. I am very sorry for messing things up... Could you take a screenshot of the game's directory?
  6. First, reduce your monitor's resolution down to 800x600. Remove every single .dll file in the root directory of Mega Man Legends directory. Don't worry about WineD3D. Instead, right-click MEGAMAN.EXE, go to Properties, Compatibility, tick Reduced colour mode and set to 16-bit colour. Make sure MEGAMAN.EXE isn't running in the background by checking Task manager. You should be able to use F7 properly now.
  7. @marioguy789 There should be a libwine.dll in the WineD3D .zip.... Sorry for the confusion and mess. 😞 Have you tried following cloudhaacker's instructions yet?
  8. @marioguy789 You don't need to set your desktop resolution that low. Use WineD3D wrapper by deleting the dgVoodoo2 and copying wine3d.dll, libwine.dll and ddraw.dll from the WineD3D .zip. Get WineD3D here: https://downloads.fdossena.com/geth.php?r=wined3dst-prevk-latest Once you are using WineD3D, you can switch between DirectX mode and Software mode effortlessly.
  9. @marioguy789 That is weird. dgVoodoo should be working... Maybe try re-installing dgVoodoo again (the .dll's, the .conf file and the dgVoodooCpl.exe). Otherwise, you could try shifting Mega Man Legends to your Desktop. If none of that has any effect, then I have no clue what is going on. Make sure to press the ./ button to update the config directory location.
  10. @marioguy789 That means that dgVoodoo isn't hooking into the game (not working at all). Try copying the dgVoodooCpl.exe into the Mega Man Legends' root directory. Make sure you are trying to rename/move the .dll's from the game's directory itself.
  11. @marioguy789 You are using the right dll's. The ones from the x86 folder (32-bit) are what you need. A troubleshooting method is to try moving/renaming one of the dgVoodoo .dll's while the game is running (D3D8.dll, D3Dlmm.dll, DDraw.dll). If you can't move/rename any of those .dll's, then dgVoodoo is working properly.
  12. @marioguy789 Set the resolution to 1920x1080 60Hz in dgVoodoo2, maybe that will help? There should be no need to press F7 at all.
  13. @marioguy789 It isn't necessary to press F7 when starting the game (at least in my experience). Try launching it without pressing it.
  14. @marioguy789 😯 D3DImm.dll is missing! You need to extract it from the MS folder in the dgVoodoo zip file. Without it, dgVoodoo2 won't work.
  15. @marioguy789 Either run dgVoodoo2 as administrator (the Control Panel itself), or copy/move MegaMan Legends to a different directory. dgVoodoo uses a .conf file to store settings, and it can't write to Program Files unless the dgVoodoo control panel is run as administrator, or the game is moved to a non-system directory (such as your Desktop or just root C:\). What framerate did you set in the NVIDIA Control Panel? I can't get the audio to loop properly still..
×
×
  • Create New...