Jump to content


Photo

Unable to create a fixbox under field of view section in an article


Best Answer Soeb , 12 September 2016 - 07:31 AM

This is because of the pipe ( | ) character in your fixbox. MediaWiki interprets it as a delimiter for a new parameter in the template. If you need to use a pipe in a fixbox, replace it with the {{!}} template, and it will appear correctly.

 

This is not a bug, but a limitation stemming from a wiki feature.

Go to the full post


  • Please log in to reply
3 replies to this topic

#1 Mars icecream

Mars icecream


  • Posts: 198

Posted 12 September 2016 - 05:09 AM

I'm trying to create a fixbox for console bind FOV method in the Killing Floor article, but for some reason formatting is always broken. I successfully created two fixboxes today in other articles.

I don't know why input settings paragraph is affected.

===[[Glossary:Field of view (FOV)|Field of view (FOV)]]===
{{Fixbox|1=
{{Fixbox/fix|Bind FOV command to a key|ref=<ref>http://forums.tripwireinteractive.com/forum/killing-floor/killing-floor-general/general-discussion-aa/89046-fov-to-small#post1719136</ref>}}
{{ii}} Game's default FOV value is 105, seems to be horizontal.
# Open console while in the game (<code>§</code> key by default).
# Recommended binding to a movement key, for example <code>set input W moveforward | fov x</code>.
# Apply by pressing enter.
}}

gKgOgeT.png

===[[Glossary:Field of view (FOV)|Field of view (FOV)]]===
{{Fixbox|1=
{{Fixbox/fix|Bind FOV command to a key|ref=<ref>http://forums.tripwireinteractive.com/forum/killing-floor/killing-floor-general/general-discussion-aa/89046-fov-to-small#post1719136</ref>}}}}
{{ii}} Game's default FOV value is 105, seems to be horizontal.
# Open console while in the game (<code>§</code> key by default).
# Recommended binding to a movement key, for example <code>set input W moveforward | fov x</code>.
# Apply by pressing enter.
}}

xwREBzl.png



#2 Mars icecream

Mars icecream


  • Posts: 198

Posted 12 September 2016 - 05:24 AM

Articles I successfully edited today, no idea what's wrong:

 

http://pcgamingwiki.com/wiki/Painkiller:_Hell_&_Damnation#Disable_intro_videos

http://pcgamingwiki.com/wiki/Evolve_Stage_2#Disable_intro_videos



#3 Soeb

Soeb

Posted 12 September 2016 - 07:31 AM   Best Answer

This is because of the pipe ( | ) character in your fixbox. MediaWiki interprets it as a delimiter for a new parameter in the template. If you need to use a pipe in a fixbox, replace it with the {{!}} template, and it will appear correctly.

 

This is not a bug, but a limitation stemming from a wiki feature.


  • Marioysikax, Mars icecream and Vetle like this

#4 Marioysikax

Marioysikax

Posted 12 September 2016 - 11:35 AM

Some other characters like [ and ] are also somewhat problematic as they are also used as characters to seperate text from wiki code. It's also possible to use HTML code like &#124; for |, but not sure which method is more preferable. 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users