Jump to content
kaydegard

Dark Souls 3 fails to Launch

Recommended Posts

I've wanted to get back into DS3 over the last while, I had the game installed previously and then uninstalled it, now I downloaded it again from Steam but it's not launching.

It just doesn't launch, if I hit play the game will show as "Playing" for a few seconds and then it will just fizzle out, I can hear the GPU fan rev up for that duration and then power down.

I've updated my NVidia drivers and PhysX, I've updated windows, did all the things in the troubleshooting guide and it doesn't work, I tried uninstalling and reinstalling several times now on both the HDD and the SSD and it doesn't work, I've tried running as admin from the game files or even from the command line but it doesn't work, I have no idea what's going on, please help!

Here are my specs on a Lenovo Legion laptop:

NVIDIA GeForce GTX 1060 with Max-Q Design
Operating System: Windows 10 Home 64-bit 
Processor: Intel(R) Core(TM) i7-7700HQ CPU @ 2.80GHz (8 CPUs), ~2.8GHz
Memory: 16GB
DirectX Version: DirectX 12

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

  • Found PCGamingWiki useful? Please consider making a Donation or visiting our Patreon.
  • Who's Online   1 Member, 0 Anonymous, 289 Guests (See full list)

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Forum Statistics

    1,321
    Total Topics
    7,197
    Total Posts
×
×
  • Create New...