Jump to content

Draugen


kizzy101
 Share

Recommended Posts

Just bought Draugen on PC. Download and install was fine but on run the game to play I get this message

DX11 feature level 10.0 is required to run the engine

I've run a dxdiag and it states that Direct X is DX11.

Can anyone help?

TIA

Kizzy101

DxDiag.txt

Link to comment
Share on other sites

“Feature level” in DirectX speech is what your hardware supports. So while you have DirectX 11 installed, your hardware itself does not support feature level 10.0 for DirectX 11.

What graphic card do you have? And have you installed the drivers for the graphics card?

 

Edit: ... Just saw your dxgi.txt file... The NVIDIA GeForce 6150SE is an /extremely/ old piece of graphic card. In fact, it’s apparently 15 years old by now ( https://www.techpowerup.com/gpu-specs/geforce-6150.c2158 )...

It’s simply too old to run any modern games created in the last decade or so as the hardware lacks a lot of necessary features that modern games (even those designed to look “old”) expects.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Found PCGamingWiki useful? Please consider making a Donation or visiting our Patreon.
  • Who's Online   3 Members, 0 Anonymous, 330 Guests (See full list)

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Forum Statistics

    1.7k
    Total Topics
    9.1k
    Total Posts
×
×
  • Create New...