Jump to content

Welcome to the upgraded PCGamingWiki forums and files page. The current Wiki and Forum bridge is not functioning at the moment, therefore your Forum account currently has no password set. Please reset your Forum password via email check to generate a new password. If you have any issues please message Andytizer on Discord.

  • 0
Jwrath

Just Cause 3

Question

It's probably a bug from the game itself but I'd like to ask anyway.

 

While Just Cause 3 works perfectly (no crashes, no lagging) I've noticed something weird. Whenever I pull down a fuel tank (the cylindrical you can find on bases and police stations) with my grappling hook, the tank simply pops. There is no explosion. While the rest of the explosions work perfectly this one doesn't. Well it doesn't happen all the time, sometimes there is an explosion (small or big) but most of the times it just pops, showing only pieces of metal on fire.

 

Is there a way to fix that (maybe by disabling Ambient Occlusion), do I have to tweak my GPU settings, is it a bug from the game itself, what?

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Related to that particular bug, it is not a graphical issues. Most definitely a game bug, although framerate can mess up game's physics and cause the problem, try enabling VSync.

 

You should see the game's forums and maybe you can find a similar issues from other users.

Share this post


Link to post
Share on other sites
  • 0

Related to that particular bug, it is not a graphical issues. Most definitely a game bug, although framerate can mess up game's physics and cause the problem, try enabling VSync.

 

You should see the game's forums and maybe you can find a similar issues from other users.

VSync stayed enabled.

 

For better performance I've disabled:

Anti-Aliasing (sometimes I set it to FXAA) even though it can go smoothly with SMAA T2x (it becomes a little laggy every now and then) but I don't want to push the system to it's limits needlessly.

Bokeh Depth of Field

Global Illumination

Edge Fade

 

Everything else is set to very high.

 

If there was a problem with the framerate, shouldn't that affect the entire game? Why affect that specific part?

By the way, in NVIDIA Control Panel I see a G-Sync option. Any idea what that is? Is it related to Vsync? Should I keep it on?

Share this post


Link to post
Share on other sites
  • 0

This is certainly not graphical issue. Perhaps that's what the game does it. As long as this is not blocking your gameplay progress, it shouldn't be much of problem.

 

By the way, in NVIDIA Control Panel I see a G-Sync option. Any idea what that is? Is it related to Vsync? Should I keep it on?

 

AFAIK, G-Sync is a better version of VSync for some supported high-end NVIDIA GPUs. It helps eliminate tearing without causing stutter and input lag, unlike regular VSync.

Share this post


Link to post
Share on other sites
  • 0

This is certainly not graphical issue. Perhaps that's what the game does it. As long as this is not blocking your gameplay progress, it shouldn't be much of problem.

 

 

AFAIK, G-Sync is a better version of VSync for some supported high-end NVIDIA GPUs. It helps eliminate tearing without causing stutter and input lag, unlike regular VSync.

 

So I should enable G-Sync from Control Panel and disable VSync from game options, right? Or keep both of them enabled?

Share this post


Link to post
Share on other sites
  • 0

This sounds like a bug related to the physics more than one related to graphical settings, but just in case, have you tried:

-setting everything to the lowest settings and trying to reproduce the bug?

-setting everything to the highest settings and trying to reproduce the bug?

If the bug is solved in either situation then it is indeed related to graphical settings, and you should therefore try to change each setting individually until you find the culprit.

 

So I should enable G-Sync from Control Panel and disable VSync from game options, right? Or keep both of them enabled?

I'm impressed that you paid the (hefty) premium to get a laptop with G-Sync and don't even know what it is :D

Check out Nvidia's website to get a proper explanation, it's a great feature.

To answer your question, if you have G-Sync on, it is not necessary to enable V-sync, and it shouldn't make a difference if it's turned on. Thoug I'd personally turn it off.

Share this post


Link to post
Share on other sites
  • 0

This sounds like a bug related to the physics more than one related to graphical settings, but just in case, have you tried:

-setting everything to the lowest settings and trying to reproduce the bug?

-setting everything to the highest settings and trying to reproduce the bug?

If the bug is solved in either situation then it is indeed related to graphical settings, and you should therefore try to change each setting individually until you find the culprit.

 

I'm impressed that you paid the (hefty) premium to get a laptop with G-Sync and don't even know what it is :D

Check out Nvidia's website to get a proper explanation, it's a great feature.

To answer your question, if you have G-Sync on, it is not necessary to enable V-sync, and it shouldn't make a difference if it's turned on. Thoug I'd personally turn it off.

All I wanted was a laptop that won't overheat to a shutdown point and this one was highly recommended. My previous Qosmio F50-10K was overheating even with Doom 3 and after 7 years of use I needed an upgrade. Plus I didn't notice any G-Sync reference in the system specs to wonder what that is. :P

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Forum Statistics

    942
    Total Topics
    6078
    Total Posts
  • Who's Online   0 Members, 0 Anonymous, 68 Guests (See full list)

    There are no registered users currently online



×