Jump to content

Street Fighter 6 - Choppiness at high refresh rates


Recommended Posts

Is anyone else experiencing microstutter when setting their monitor to refresh rates above 60hz? I have to set my monitor to 60hz and turn vsync ON in the settings to get playable gameplay. As soon as I go to 120hz or 144hz, the stuttering returns. This is 1v1 / training only - I am ignoring battle ground for the purposes of this thread. Basically, vsync seems to be broken.


Toggling vsync, maximum framerate or any other graphical setting seems to make no difference.


Have tried:

1. Disabling gsync

2. Disabling steam overlay

3. Disabling nvidia geforce experience overlay

4. Disabling core isolation (~5% perf hit)


Street figher V ran like a dream at 144hz natively with considerably less input lag. Has anyone else experienced this problem?




RTX 2070

32GB ram


In summary:

Monitor @ 60hz with vsync ON = playable

Monitor at @ 120hz with vsync ON / OFF = stuttering mess


Out of curiosity, I ran some benchmarks using Nvidia's FrameView during 1v1 matches:


Application Runtime Avg FPS 1% Low FPS
StreetFighter6OpenBeta.exe D3D12
StreetFighter6OpenBeta.exe D3D12
StreetFighter6OpenBeta.exe D3D12
StreetFighter6OpenBeta.exe D3D12
StreetFighter6OpenBeta.exe D3D12

Overall performance is just poor in 1v1, even @ 60hz with vsync enabled. It's not a complete mess like 120 or 144hz, but it's still poor. 

Link to comment
Share on other sites

  • 4 weeks later...

Just picked up the game myself, and am having much the same issues as you're stating. A lot harder at the moment to search forums for anyone with the same issue, as a lot of reddit is private now. 

Trying everything you had mentioned, I have the same issues where the 1% lows are in the 30s, and the game is reporting "60fps" when it's more often at 59. All in all it just feels awful to play, and I'm wondering if I should've just gotten it on console instead. Frustratingly enough, using the official benchmark tool only highlights these issues. In every other section of the demo: world tour, battle hub, etc, the game has a flawlessly paced 60fps in effect. The beginning of the test in the fighting ground (you know, the actual game) has frequent dips and painfully apparent microstutters despite reporting an average of 59.89fps.

For posterity, specs: 

RTX 4090

Display is an LG C9 OLED, and the PC resolutions don't even give an option for 60hz unfortunately-- just 120hz and 100hz, unless I go to TV resolutions. 

Link to comment
Share on other sites

I found a solution, you may like to try it as well.

I also use an LG (Ultragear) monitor, and have my arcade stick plugged into the rear of the monitor. The monitor is then connected to the PC via USB (and displayport for picture).

I disconnected the USB connection from the monitor to the PC, and instead connected the arcade stick straight into the PC. Left the monitor USB connection unplugged and closed the lg on-screen view (making sure to take it out of startup apps in task manager). Rebooted. 

Voila, no more frame drops (with any settings). Hopefully it works for you as well!

Link to comment
Share on other sites

Glad that ended up working for you! Unfortunately that fix wouldn't be applicable to my screen, as this is just a 4K OLED tv plugged HDMI into the pc. Arcade stick and ps5 controller both have been tested and plugged into various USB ports, I also disabled Microsoft Device Association Root Enumerator at someone's suggestion, and no matter what, constant microstutter. 

I set through windows instead of nvidia control panel the refresh rate of the monitor, as that method gave me a 60fps option, and it feels the least bad of all the options so far. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...