Jump to content


Photo

Total war Crash - mss32.dll etc.

total war shogun 2 empire total war napoleon total war total war crash total war mss32.dll shogun 2 crash

  • Please log in to reply
8 replies to this topic

#1 The high king

The high king


  • Posts: 5

Posted 2 weeks ago

Hi, I really hope someone can help/assist me. I would respectfully request that you read the full post before commenting, thank you.

 

Monetary reward of £50.00 donation to this website - PC Gaming Wiki if a member of PC GAMING WIKI can resolve this problem

or;

STEAM GAME or combination of games of your choice worth up to £50.00 to the person who provides with with a guaranteed tested working fix to this problem.

 

I have a long running problem with the following total war games crashing:

 

Empire Total War

Napoleon Total War

Shogun 2: Total War

 

The issue is always the same - the games crash randomly and somewhat frequently when playing a battle on the battle map.

 

The error reports generated by windows state that the problem is almost always caused by a fault module with mss32.dll as well as others, sometimes including ndll.dll.

 

The issue is not exclusive to this machine, operating system, OS version, or specific hardware.  I have had 3 different computers, all with different hardware and OS versions at some point and the problem persists/has persisted no matter what the hardware or OS setup.

 

For example, the first machine I had this problem with was a  Intel core 2 duo 3.00ghz, 2 GB RAM, a ATI 4870 video card, Windows XP (upgraded to vista and then 7 - 32bit and 64 bit versions as the system was 64bit ready.); the latest system is a Intel quad core 3.60 GHZ overclocked to 3.9GHZ, 16 GB RAM @ 1600 frequency, Nvidia 980TI 6 GB video card Windows 7 64bit / Windows 10 64 bit dual boot.

 

Sound cards used have mostly been onboard sound provided by realtek, but have also used a high end Creative sound card and have suffered exactly the same issue.

 

My drivers have always been and remain constantly up to date wherever possible, especially video and sound drivers.  My motherboard has the latest BIOS version installed.

 

I have tried every solution I have come across to tackle this problem and NONE have fixed the issue despite hours of searching for help on forums and the internet at large, including youtube.

 

My main concern is finding a solution to shogun 2 as it is my favourite total war game with the exception of Atilla and Warhammer.

 

I realised that the problem is the same with the 3 games listed at the top of the post  as opposed to the latest total war games because they all have Miles Sound system as part of the software, whereas, Rome 2, Atilla and Warhammer total war titles do not, and I therefore do not have this issue with the latest titles crashing. MSS32.DLL is the file associated with the fault 99% of the time.

 

I have asked several forums for extensive assistance with this issue only to find no solution in the end, despite some really helpful people and suggestions, usually moderators.  I have contacted both Sega (useless and pointless at the same time - the techical support they offered on several occasions was laughable at best, they truly are clueless), Creative Assembly (no reply) and also the creators of the miles sound system programme (no reply).

 

Below are the methods and attempts I have made to fix the issue - please read as most people seem to overlook this when raising the issue:

 

*Deleted specific files in the userapp folders, data folders, scripts, preferences etc (they get regenerated during a "verify integrity of game files" approach via steam.)

*Deleted dll files (they get regenerated during a "verify integrity of game files" approach via steam also, this includes files such as mss32.dll, shogun2.dll etc.

*Verify integrity of game files via steam (have lost count how many times I have done this)

*place certain folders i.e. mss32.dll into windows 32 folder and WOW 64 folders (no difference made in the end)

*Uninstall and reinstall game, by completely deleting all files associated with the game.

*Install/reformat/reinstall windows and different operating systems (have used windows xp 32 bit, windows vista 32 bit, windows 7 64 bit, windows 8.1 64 bit and currently windows 10 64 bit) - at the moment I have a dual boot option with the same issue occurring on both operating systems.

*Delete programmes which may interfere with mss32 such as itunes for example.

*Played the game offline and online through steam

*have used ccleaner to clean and fix registry problems in windows

*Uninstalled Norton Security

*updated windows (which for windows 7 is virtually impossible these days due to the push to get people on windows 10

*check constantly for viruses and malware (NEVER any found no matter what security program I use, system always appears to be virus and malware free)

*tired playing the game in both directx9, directx10 and currently direcx11 and 12. (no difference in the frequency or kind of crash)

*updated/reinstalled/clean reinstall of drivers

*changed graphics settings for all 3 games, using both maximum and minimum settings, crash still occurs no matter the graphics option. my most recent systems have had no problem with lag on these games when max graphics applied anyway.

*tried using different mss32.dll files with the game (as a result the game refuses to start and then reacquires the correct version anyway upon verify integrity option.

*use scandisk/checkdisk for errors with hardware (none found)

*used many different tools for stressing and testing hardware components to check that hardware is not the problem (which never it has never come back with any problems hardware related

*Disconnect the internet pfft? no change.

*I do not use any mods for ANY total war game with the exception of Rome 2 and this is therefore not mod related problem and never has been.

 

There are other things I have tried but at this moment in time cannot think of them. Needless to say, I have tried just about everything I have come across - the issue remains. I have even specifically purchased new computers and hardware to combat this particular problem - same issue, every time.

 

For clarification - this problem only happens with total war games that use the miles sound system and therefore mss32.dll and other related files and the warscape engine (meaning I do not have this issue with the likes of Medieval 2 total war and Rome 1 total war).  Since Creative Assembly (thankfully and mercifully) stopped using Miles Sound System with the warscape engine, the issue does not affect Total war Rome 2, Total war Atilla or Total war: Warhammer - which I CAN play with no problem at all with slight driver exceptions which are easily fixed. Following this, I can play the latest total war games on full settings with no problem, and can therefore only come to the conclusion that this is definitely NOT a hardware problem and that it points to either a general software problem, a problem with the actual games using miles software (which doesn't explain how some people can play with no issue at all whilst others cannot?) or a software issue in general (help required, patch required, anything really?)

 

Why do I bother?

 

I have spent a great deal of money, time and effort trying to find a fix for this with no solution.  The reason I do this is because I love the total war games, especially Shogun 2 and have done since the days of medieval 1. to some, it's too much effort and not worth bothering about. To me, it means a great deal, and as I have come across many people via forums and internet searches with this and similar issues, I can only assume it means a great deal to others as well.

 

Whilst I would suggest that the issue remains a problem with Creative Assembly and Sega and that they should be the ones to fix the problem, I doubt very much this is going to happen after 6 years . Trying to get help with the problem via SEGA support simply proves that some departments are not worth having and that certain tech support people should be out of a job! Harsh as it seems, but they are not the only video game publisher who have this particular approach.

 

I am therefore asking ANYONE who have any idea what the problem is and how to fix it to help me (and others). If a patch could be created, officially or unofficially it would be welcomed.  I am more than willing to troubleshoot the issue again, though would request guidance when doing so this time around in case I am doing something wrong?  I will post error reports (I have plenty) and a dxdiag from both win 7 and 10 if needed.

 

ALL games have been purchased legitimately via certain retailers and have all been installed via steam (as well as a multitude of all additional DLC) and so this isn't a pirate software issue.

 

As stated at the top of the post, I am willing to offer a financial reward/incentive for a permanent and TESTED fix or work-around for the problem, as well of my eternal gratitude.

 

All help is appreciated. All suggestions are welcomed.

 

Thank you in advance.

 

p2. 1. dxdiag provided via attachment - update - failed to upload, tried twice? any suggestions?

ps. 2.example of latest error reports (mss32 & ntdll)

 

Description
Faulting Application Path:    E:\Program Files (x86)\Steam\steamapps\common\Total War SHOGUN 2\Shogun2.exe

Problem signature
Problem Event Name:    APPCRASH
Application Name:    Shogun2.exe
Application Version:    1.1.0.0
Application Timestamp:    507716b8
Fault Module Name:    mss32.dll
Fault Module Version:    8.0.3.0
Fault Module Timestamp:    4bf2900c
Exception Code:    c0000005
Exception Offset:    00016eb9
OS Version:    10.0.14393.2.0.0.768.101
Locale ID:    1033
Additional Information 1:    2beb
Additional Information 2:    2beba6fb4680d73a8c78ca7c24ccdb46
Additional Information 3:    1055
Additional Information 4:    10551cc64bcfba7d2297b81a9c0092f2

 

Description
Faulting Application Path:    E:\Program Files (x86)\Steam\steamapps\common\Total War SHOGUN 2\Shogun2.exe

Problem signature
Problem Event Name:    APPCRASH
Application Name:    Shogun2.exe
Application Version:    1.1.0.0
Application Timestamp:    507716b8
Fault Module Name:    ntdll.dll
Fault Module Version:    10.0.14393.479
Fault Module Timestamp:    58256ca0
Exception Code:    c0000005
Exception Offset:    0003ff33
OS Version:    10.0.14393.2.0.0.768.101
Locale ID:    1033
Additional Information 1:    e2a5
Additional Information 2:    e2a5934c14e66921972cbe137a4819ff
Additional Information 3:    3779
Additional Information 4:    3779a10c3ea533989b4f726af0a4a6f0
 

Thank you kindly.

 

Attached Files



#2 Mirh

Mirh


  • Posts: 785

Posted 2 weeks ago

Try to fix codec hell.

Does playing .bik in game folder with mpc-hc works then?

 

Could you run process monitor alongside the game, then attach somewhere a log of when it crashes?

 

And FIY the free W7 upgrade promotion ended. If any it was a hell to update because microsoft had some memory leak/loop/madness in wu service, but it should now be viable.



#3 The high king

The high king


  • Posts: 5

Posted A week ago

Hi Mirh, thank you for replying.

 

Ok, just a couple of things I may need help with.

 

Firstly, I'm not entirely sure what you mean by playing .bik in game folder with mpc-hc? Can you please clarify and provide more information or some instructions as to how to do this for testing purposes?

 

Secondly, I can certainly run process monitor alongside the game no problems here, but how would I go about attaching a log of the crash via the process monitor?

 

In respect of the windows 7 update problems, unfortunately it is still a case (on my pc and my mothers at least) that windows 7 seems to be unsupported in terms of windows updates. I have even left the check for windows updates programme running for several hours with no progress whatsoever. Unfortunately, I think this is a push toward windows 10 via bullying techniques by Microsoft. Could be wrong of course.

 

I have had a brief look at the codec hell page you referenced, thank you very much, I will take a better look at it tomorrow when I should have a little more time to do so.  In regards to mpc-hc - would this improve my situation any simply by installing it?

 

On a side note: Since posting I had the idea of making the mss32.dll file which comes with the game 'read only'. So far it seems to have made the game more stable, but then again, the game can go for a couple of days without crashes, and then be hounded by them, so, not sure of any result at this point without further testing.

 

Thank you again for the info and response, I look forward to the next reply.



#4 Mirh

Mirh


  • Posts: 785

Posted A week ago

Don't try to make all that sense from what I say.

Since you claimed to have done really a lot of stuff (even though tbh 3/4 is simple wtf meaningless) I'm going full "brainstorming".

 

Mpc-hc is this. It's just a program like another that can read biks. Just want to make sure whatever is being read is fine.

 

2. Just keep procmon open while you play (preferably filter out other processes). When it crashes stop logging, save report into a fail and attach it somewhere.

 

3. That's just microsoft going full retard around the same time of W10 release (W7 problem though isn't directly related to that). This should help (it's a pretty known, normal and surpassed problem by now).

 

4. Nope.

 

5. Not like I want to be pitiless, but dlls are already bloody read-only files conceptually. Process needs functions, load library, do whatever it has to do. But you really don't touch it. And anything you did is certainly a placebo (assuming you didn't also change your behavior somehow, in which case something may be at play).

 

I think you may also want to try to install debugging tools for windows (here), and get a memory dump of the crash.

EDIT: other idea



#5 The high king

The high king


  • Posts: 5

Posted A week ago

Look, I got to be honest, I have no idea how to save a report/log of process monitor/task monitor - the option simply does not exist.

 

Game is continuing to crash as usual today, so the latest changes were as you say - meaningless. I will D/L mpc-hc before the next time I run the game.  What I can do incidentally is to provide you with a crash log generated by the game itself, but as I am unfamiliar with the file type associated with the log I have no idea how to open them or how to read them - see attached.

 

And at the moment I don't see any point to using debugging tools as I wouldn't have the foggiest idea of how to use them unfortunately.

 

I do know one thing, and that is that the game crashes are strongly connected to miles sound system - or at least according to crash logs they are.

 

EDIT: UNfortunately I am unable to provide you with the crash logs generated by the game as I receive this message when attempting to do so:

'You aren't permitted to upload this kind of file'.

 

the file is a .mdmp file which I assume is a minidump?  Any suggestions?

 

Cheers.

 

 



#6 Mirh

Mirh


  • Posts: 785

Posted A week ago

You don't need, have and should upload logs here on PCGW.

In procmon it's the usual File>Save ?



#7 The high king

The high king


  • Posts: 5

Posted A week ago

Hi Mirh,

 

Ok, you have to provide more instruction, because I haven't got the slightest idea how to use Microsoft 'windows software development kit' that downloaded when I downloaded visual studio? I have had a look through the files and honestly don't have a clue what I am looking for even with information explaining (badly) how to use it for debugging.

 

I'm not computer savvy in this respect and only know how to do the basics, so I will need clear instructions from here on in.

 

Still cant attach the minidump file to the forum, not even if I winrar it.  Again, need more help with this, because at the moment I feel like I am trying to learn Mandarin.

 

I will take a look at procmon, but again, I don't know what I am doing with it, as online information is not exactly clear to the uninitiated of this kinda stuff.

 

Thanks, look forward to hearing from you.



#8 Mirh

Mirh


  • Posts: 785

Posted 6 days ago

File, Save.. It's the same than in Word.

 

If you already got the memory dump some other way then, debugging tools are useless. But as I said, for the love of god, attach it somewhere else. It's not like posterity will care about that.



#9 The high king

The high king


  • Posts: 5

Posted 19 hours ago

OK, had a really bad couple of days, sorry for the delay.

 

I think there is an issue of miscommunication going on here. Again I am not a computer techie and so I don't have the level of knowledge that I think you think I have.  I simply use computers to play games, go on the internet and save documents and photographs etc. Beyond that, I am clueless, and quite frankly I am angered by the fact that neither Creative Assembly nor SEGA have attempted to address this issue and fix it.  It shouldn't be left down to the likes of me to search the internet for HOURS and hours on end looking for a solution to a problem I know nothing about and do not understand.  So please keep that in mind.

 

When you asked me to use process monitor and save the read out I was under the impression that you meant task manager and process manager via control-alt-delete.  I had never heard of a programme called procmon before, so understandably I was a bit confused. I have now downloaded the programme, run it during the course of the game and have saved the file following a crash with shogun 2.  However, when I try to open it, I can't and it gives me an error? If you tell me where on this forum I can post error logs and other files which is both secure and accessible, I will do so.

 

With regards to the minidump error log that is created when the game crashes (sometimes - often it doesn't for some reason). I can provide you with a copy of this log/minidump IF you tell me where exactly I can post it on the forum, because it will not allow me to post it in this thread.

 

I have tried several methods and programmes to try and enable me to read the minidump but all I get is scrambled code. I have downloaded the visual studio you linked me to - which I have no idea at all how to use it, but not only that, but it seems to have uninstalled itself along with the media player you suggested - a windows 10 bug I suspect.

 

Again, if you provide me with instructions as to exactly what I am suppose to do with it, I will use it to attempt to debug/read the minidump.

 

The MPC media played you asked me to download, I have no idea what the purpose of that was, as it has made no difference to the stability of the game, and it crashes just as usual.

 

Suggestions?






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users