Jump to content

Fable The Lost Chapters doesn't work anymore


Recommended Posts

I recently had to reinstall Windows 7 because of something stupid I did, but for whatever reason Fable doesn't play anymore, everytime I start the game I get a message saying "couldn't find localization file" afterwards I see and hear the splash screens but as soon as it gets to the menu, theres no sound.

Anytime I start a new game or load an old save the game hangs on a black screen and if I try to exit the game I also get a black screen.

What is causing this problem?

pic related.jpg

Link to post
Share on other sites

I've placed a no-cd exe over the normal one and I don't get the "couldn't find localization file" message anymore, everything else is still the same, I noticed however that right after the splash screens there is a very brief moment you see the Windows aero windows (as if it was maximising or something) and can't remember that being normal.

 

On 9/9/2021 at 4:53 AM, mrpenguinb said:

Try changing the language used by the game.

Check to see what Window's language is selected in Windows.

There isn't any language you can choose, Windows is English, it was something else before it.

22 hours ago, Airo24 said:

This unofficial patch might fix your problem.

Didn't change a thing.

Link to post
Share on other sites

Sounds like a reg issue.

 

Though i can't remember if this game stores any settings in the registry.

The game was working ok until you reinstalled windows which would have wiped the registry and also appdata or document folders that might have had some config files related to the game.

Though maybe this is a clean install game that doesn't have any stuff like that.

Is this an old xlive game ? Maybe the xlive fix would work or the new goldberg files.

Pretty sure this game has been mentioned a few times in the xlive thread on cs.rin.

Link to post
Share on other sites
5 minutes ago, dootoo said:

Sounds like a reg issue.

 

Though i can't remember if this game stores any settings in the registry.

The game was working ok until you reinstalled windows which would have wiped the registry and also appdata or document folders that might have had some config files related to the game.

Though maybe this is a clean install game that doesn't have any stuff like that.

Is this an old xlive game ? Maybe the xlive fix would work or the new goldberg files.

Pretty sure this game has been mentioned a few times in the xlive thread on cs.rin.

I did a clean reinstall, deleted any kind of registry and stuff in appdata involving Fable, but still the same thing, no it's not an old Xlive game, it's just the retail version

fables.JPG

Link to post
Share on other sites
8 hours ago, bez said:

There isn't any language you can choose, Windows is English, it was something else before it.

What language was it before? Maybe because the language has changed, the game can't handle switching. Either way the whole situation is really weird.

Link to post
Share on other sites

Dutch, but I reinstalled Windows first in that language and got the same problem when I installed it in English, also, I installed Fable on a friends computer with the same (english version) and the game worked perfectly there.

Link to post
Share on other sites
6 minutes ago, bez said:

Dutch, but I reinstalled Windows first in that language and got the same problem when I installed it in English, also, I installed Fable on a friends computer with the same (english version) and the game worked perfectly there.

If you know how to use Process Monitor, you could monitor what files are missing or causing issues (add Fable.exe to the filter) Other than that, I'm stumped.

Link to post
Share on other sites
On 9/11/2021 at 2:44 PM, mrpenguinb said:

If you know how to use Process Monitor, you could monitor what files are missing or causing issues (add Fable.exe to the filter) Other than that, I'm stumped.

Took a look and for some reason quite some files are supposedly missing or are read only

Link to post
Share on other sites
On 9/13/2021 at 1:12 AM, bez said:

Took a look and for some reason quite some files are supposedly missing or are read only

Those are normal messages in Process Monitor, don't worry.

11 hours ago, bez said:

Also tried the Steam version directly from Steam (so completely legit) same problem even there.

Check to see the language settings on a computer where the game works and see if there are any language/region differences with your main computer.

If you want to, you can do a Process Monitor log/capture on the computer that has the issues and take another log/capture on a different computer where the game works, you can then compare the captures. To compare the captures, export both of the captures to .CSV files and use WinMerge to compare the captures.

Link to post
Share on other sites

I don't know if it might help, but at the time (back when I still played it on Windows XP) I had problems playing this game, no clue of any sort, and after a few things tried I found out that the problem was this game had a problem with the new skin I installed to modifiy the Windows inteface, so maybe it might be something like that.

Did you installed something that wasn't there when it was still working? (even something that might not look related)

Maybe trying to change the compatibility, disabling stuff?

Link to post
Share on other sites
44 minutes ago, greenyoshi said:

I don't know if it might help, but at the time (back when I still played it on Windows XP) I had problems playing this game, no clue of any sort, and after a few things tried I found out that the problem was this game had a problem with the new skin I installed to modifiy the Windows inteface, so maybe it might be something like that.

Did you installed something that wasn't there when it was still working? (even something that might not look related)

Maybe trying to change the compatibility, disabling stuff?

Do you mean as the Windows interface? Or the ingame interface of Fable? Either way, The only difference between then and now is that I use Windows Aero instead of Windows Classic. I also tried compability options, no change.

Link to post
Share on other sites
23 hours ago, bez said:

Do you mean as the Windows interface? Or the ingame interface of Fable? Either way, The only difference between then and now is that I use Windows Aero instead of Windows Classic. I also tried compability options, no change.

Try using the Windows Classic theme, even though it really shouldn't matter.

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
  • Found PCGamingWiki useful? Please consider making a Donation or visiting our Patreon.
  • Who's Online   1 Member, 0 Anonymous, 314 Guests (See full list)

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Forum Statistics

    1,512
    Total Topics
    8,163
    Total Posts
×
×
  • Create New...