Jump to content
marioguy789

Mega Man Legends Installation on Windows 10

Recommended Posts

@mrpenguinb

Aaaaaahhh... Thanks, I just corrected that mistake, sorry. 

The bad news is that now I'm encountering another problem where after I've placed that into Mega Man's root directory, F7 simply tries to window and then crashes the game to desktop.

Share this post


Link to post
Share on other sites

@mrpenguinb

In @cloudhaacker's video, he lists in the description that "Once your loaded into the game, push F7 to set the renderer to DirctX Wrapper."  When I do this, the game tries to window and crashes.  Even with me placing all of the required files into the root directory and having the correct settings, the game doesn't look like it is shown in the video.  I don't know why, it just doesn't.

Share this post


Link to post
Share on other sites

For example, this is with all settings as they were with everything where it's supposed to be (pardon me trying to screenshot media player, but it's the fastest way for me to do this):825039657_MegaManLegendsP5.thumb.PNG.a7776442972c3dc476b972385f547505.PNGAs you can see, the lighting is still broken and everything is still very aliased.

Edited by marioguy789
Clarification

Share this post


Link to post
Share on other sites

@mrpenguinb

Unfortunately, changing the refresh rate didn't seem to do anything either.  Would the issue, by any chance, be related the MS files I'm using, because I've been using the x86 version from dgVoodoo, because Mega Man Legends is a 32bit program, correct?  If this isn't the case, then I'm pretty much out of ideas.

Share this post


Link to post
Share on other sites

@marioguy789

You are using the right dll's. The ones from the x86 folder (32-bit) are what you need.

A troubleshooting method is to try moving/renaming one of the dgVoodoo .dll's while the game is running (D3D8.dll, D3Dlmm.dll, DDraw.dll).

If you can't move/rename any of those .dll's, then dgVoodoo is working properly.

 

Share this post


Link to post
Share on other sites

@mrpenguinb

I just tested this out and I was able to remove the D3D8.dll file from the directory without affecting anything.  So, since that is the case, in what way is dgVoodoo not working correctly, so that I can try and fix it?

Share this post


Link to post
Share on other sites

@marioguy789

That means that dgVoodoo isn't hooking into the game (not working at all).

Try copying the dgVoodooCpl.exe into the Mega Man Legends' root directory.

Make sure you are trying to rename/move the .dll's from the game's directory itself.

Share this post


Link to post
Share on other sites

@mrpenguinb

dgVoodoo is now in the root director for Mega Man Legends and nothing seems to have changed.  There was a configuration file included with the Unfinished Business patch, which I read in at least one place that messes with the full screen ability of the game, so I didn't copy that over and just left the default config that the game generates.  I don't know if that has to do with anything, just thought I'd mention it.

Share this post


Link to post
Share on other sites

@marioguy789

That is weird. dgVoodoo should be working... Maybe try re-installing dgVoodoo again (the .dll's, the .conf file and the dgVoodooCpl.exe).

Otherwise, you could try shifting Mega Man Legends to your Desktop. If none of that has any effect, then I have no clue what is going on.

Make sure to press the ./ button to update the config directory location.

Share this post


Link to post
Share on other sites

I went back to check and I was having issues using F7 after getting it all going. Here's how I fixed it lol. Open up dgVoodoo and on the DirectX tab check Disable & Passthrough to real DirectX. We have to turn it off temporarily to change the renderer. Then set your desktop resolution to 640 x 480, again this will be temporary it just prevents everything from resizing and causing crashes. Start the game, and once it starts try pressing F7. In the first cutscene with the ship and the clouds you should see an immediate effect, the clouds look like they're outlined when DirectX wrapper is turned on, and the door will look right in the first scene after starting a new game, otherwise the door is almost black. Once you have the right renderer picked, use F9 to exit to menu then again to exit game, set your desktop resolution back and uncheck the Disable box in dgVoodoo to renable it. Should work. Here's a few comparison screenshots to show the differences.

Screenshot 2_14_2021 9_22_46 PM.png

Screenshot 2_14_2021 9_22_50 PM.png

Screenshot 2_14_2021 9_23_09 PM.png

Screenshot 2_14_2021 9_23_12 PM.png

Share this post


Link to post
Share on other sites

@mrpenguinb

This just keeps getting me more and more confused.  First, my version of WineD3D didn't come with a file called "libwine.dll," second, when I deleted dgVoodoo2 and all of its files from the directory, I launched the game, but there was no task running, and now my third monitor looks like this:  592039189_MegaManLegendsP6.thumb.PNG.8d6f3b3453316d81568aa007d37f02d9.PNG

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

  • Found PCGamingWiki useful? Please consider making a Donation or visiting our Patreon.
  • Who's Online   0 Members, 0 Anonymous, 233 Guests (See full list)

    There are no registered users currently online

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Forum Statistics

    1,449
    Total Topics
    7,862
    Total Posts
×
×
  • Create New...