Jump to content
Mr. Doomguy

Listing the required packages for Linux version

Recommended Posts

I've been thinking about adding a list of packages that are required for the game to work on Linux in a dropdown table which is divided into popular distributions besides Ubuntu. So if someone who runs under Manjaro for example, could take a look on what package they should install in case if the speficic *.so file is missing. Can be very useful for those who own either an older Linux port or decide to run the game with native library instead of those that are included (Such as those from Steam. Since by default it still uses the ones from Ubuntu 12.04)

 

For example:

 

1st row: openal:i386, sdl2:i386 - Ubuntu, Debian

2nd row: lib32-openal, lib32-sdl2 - ArchLinux/Antergos/Manjaro

3rd row: openal:i686, sdl2:i686 - Fedora

 

As there's the ldd command which lists the SO library files, it may confuse the newcomers as they won't know which package has it. Some libraries are even in the other one you won't expect. However, most package managers have an option to locate which package has the specific file required to run.

 

EDIT: Would placing the dropdown table fit under the System Requirements for Linux? I can't help but feel that it's a good place to put it.

Share this post


Link to post
Share on other sites

  • Found PCGamingWiki useful? Please consider making a Donation or visiting our Patreon.
  • Who's Online   2 Members, 0 Anonymous, 226 Guests (See full list)

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Forum Statistics

    1,410
    Total Topics
    7,622
    Total Posts
×
×
  • Create New...