Jump to content

Broken .NET Framework in Windows 8.1

Recommended Posts

I've got a problem running the server emulator for NFS World.


This thing requires .NET Framework in order to work. It used to work just fine on my laptop, but it stopped after I reinstalled Windows. When I try to run the emulator, it displays a generic error message which says "The program has stopped working". I checked the system event log and I've found this entry (sorry it's in Polish):

Pakiet błędów 129130068170, typ 5
Nazwa zdarzenia: CLR20r3
Odpowiedź: Niedostępny
Identyfikator pliku Cab: 0

Sygnatura problemu:
P1: offlineserver.exe
P3: 56673faf
P4: mscorlib
P6: 53a11d88
P7: 23fe
P8: 28
P9: System.NotSupportedException

Dołączone pliki: 

Te pliki mogą być dostępne tutaj:

Symbol analizy: 
Ponowne sprawdzanie rozwiÄ…zania: 0
Identyfikator raportu: ceb93311-3168-11e6-830e-28d24428ae29
Stan raportu: 4104
Skrócony pakiet: 9ff1b1a9e31d886fa5a9ca063255463a

Line P4 shows that the problem is related to something called mscorlib. I googled it and it's a .NET Framework component. I've tried removing .NET from Windows Control Panel, then using .NET Framework Cleanup Tool and reinstalling the Framework, but it didn't help. Is there any way to fix this without reinstalling the whole system?


My laptop is Lenovo y510p and it runs on Windows 8.1 x64.


EDIT: Here's a Process Monitor log: https://mega.nz/#!V0Uw0TZL!sHWBqgB2hdiEQXspmMO5YbMuDaLyRPt98Ga8Po_-xSw


EDIT2: The program works normally on another Windows account! That's strange...

Share this post

Link to post
Share on other sites

That's not like one of the most specific error messages ever.

That just means .NET threw the exception, which is just what runs the program.


The only interesting thing is that "System.NotSupportedException" there (for example, I get System.IO.DirectoryNotFound when I just copy the executable with no additional folder).

While the only notable facts between W8 and .NET are these.

But for as war as my procmon log tells me, we are just talking of NET 2, also 4 at most.




I notice the program has <requestedExecutionLevel level="highestAvailable" uiAccess="false" /> in its manifest though.

Which.. at least on my account asks for admin permissions. I don't know on yours. 

Are you sure your account has all the required privileges then?

Share this post

Link to post
Share on other sites

The problem is solved. As you said, there was something wrong with my account; I created a new one on my computer and there the program worked flawlessly. So I copied my stuff to the new account and deleted the old one.

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Found PCGamingWiki useful? Please consider making a Donation or visiting our Patreon.
  • Who's Online   0 Members, 0 Anonymous, 278 Guests (See full list)

    There are no registered users currently online

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Forum Statistics

    Total Topics
    Total Posts
  • Create New...