Jump to content
Manticore

Windows 10 Threshold 2 - games crash

Recommended Posts

Check if the stupid xi.dll is still loaded.

 

And there must be something wrong with your filters in pm if I can't see any game resources being saved or loaded in the logs.

Share this post


Link to post
Share on other sites

I've checked the xi.dll and the games don't load it, so it's been removed for sure.

 

As for the filters, I use only default ones + a custom filter which includes only records related to the game's executable.

 

I've also made a test with NFSMW. I've tried to change resolution and it freezed as usual. Then I looked at the Process Monitor and here's what I found:

 

The game saves its graphics settings in HKCU\Software\Classes\VirtualStore\MACHINE\SOFTWARE\WOW6432Node\EA GAMES\Need for Speed Most Wanted. Resolution setting is saved in g_RacingResolution value. There are two records in the whole log where the game uses this value, I assume the first one was created when I launched the game and the second one when I tried to change the resolution. Both records are marked as "SUCCESS".

 

EDIT: I've checked Windows log for CMR2.0. The problem with this game is caused by kernelbase.dll.  The game works with the latest WIP version of dgVoodoo 2.

Share this post


Link to post
Share on other sites

.-. Of course the game saves there if you aren't running it as administrator.

You always should when HKLM or program files folder are involved. 

Share this post


Link to post
Share on other sites

Don't you think I tried running the game as administrator? I did, but it didn't fix the problem.

 

A new fact: the problem with freezing only occurs when the game is running in full screen mode. When it's running in a window, I can change the graphics settings without any problem.

Share this post


Link to post
Share on other sites

Don't you think I tried running the game as administrator? I did, but it didn't fix the problem.

I read what you wrote.

But then it doesn't make sense the game is using the virtualstore fallback.

 

What if you delete it?

Share this post


Link to post
Share on other sites

My bad, I should have been more specific.

 

When I delete the key nothing changes, I still get the freeze.

 

And by the way, WineD3D libraries don't work either. The games crash immediately after start if I try to force them to use Wine libraries.

Share this post


Link to post
Share on other sites

... Except my laptop isn't even compatible with Shadowplay... and the services are disabled (NVIDIA Network Service, NVIDIA Streamer Network Service and NVIDIA Streamer Service). So what now?

Share this post


Link to post
Share on other sites

100% sure. I even disabled NVIDIA Display Driver Service and NVIDIA GeForce Experience Service, and that freeze still happens :(

 

EDIT: OK, maybe this will help a little. I've made two different logs when running NFS Most Wanted. One of them was made when the game freezed, the other when I run the game through MS Application Compatibility Toolkit with DXMaximizedWindowedMode enabled (this fixes the freeze, but not in every game): https://mega.nz/#!pg1QCD7D!Dm0sFgCfaL3Vx4OGOa4-Zz-8js7BO4IW26XktB2iALo

Share this post


Link to post
Share on other sites

It indeed was loaded, but after I've changed the name of the dll so that it doesn't load, the game still freezes. So I guess Shadowplay is not to blame after all...

 

EDIT: I've noticed that this problem affects only games which use DirectX 9. Any older game (DX 8 and below, 3dfx through nGlide) or newer (DX10, 11) is OK.

Share this post


Link to post
Share on other sites

Wait wait wait. You don't change names to dlls, just because.

I think you should pinpoint whatever is going on to have a clue.

 

For example, try to uninstall the whole geforce experience as suggested here

Or hell, uninstall every kind of software related to nvidia and only reinstall the bare raw strictly indispensable minimum (ie drivers).

Share this post


Link to post
Share on other sites

Removed Nvidia drivers with DDU. Deleted every Nvidia related folder from C:\. Installed only the 355.98 driver, without PhysX or GF Experience. Games still freeze.

 

https://forums.geforce.com/default/topic/898690/geforce-drivers/windows-10-playback-freezing-in-fullscreen-video-modern-ui-apps-drivers-at-fault-/

This guy has a similar problem, only with Modern Apps running full screen rather than games. I'm starting to think that MS simply screwed something up with the November Update...

 

OK, I've found something. There's a neat tool in Windows called Event Viewer. Now please excuse me as I have Polish Windows, so my translation may not be accurate.

 

Anyway, the same moment the game freezed, an event appeared in the Event Viewer under System section. I've attached a screenshot below. Please don't ask me to translate this, because this sentence was clearly written by a monkey, not a Polish person - the language is so broken that I, a native speaker, can't understand it. The message says something about lack of privileges for user ZARZÄ„DZANIE NT\SYSTEM (user ID: S-1-5-18) for CLSID {D63.... etc}. It also says that this can be modified by MS Management Console.

 

So this wasn't driver issue after all, this has something to do with privileges. Now the question is - how the heck do I fix this?

post-1780-0-72773500-1448313417.jpg

Share this post


Link to post
Share on other sites

TL;DR: Reformat and check if these issues still persist just in case, use GameSave Manager to backup any save games. Don't install GeForce experience yet. If the issues are there, maybe revert to a previous version of Windows 10 or keep doing what Mirh wants you to do.

 

(I need to stop rambling, but it does kinda help to be honest, it sucks for anyone who sees these threads though, seeing as they have to sit through all of this crap)

 

You didn't reformat yet? That seemed like the easiest solution to me. Then you could just reinstall any drivers you need and the games you had and test them again.

 

Maybe if I was actually there I could figure out what was going on, but you might as well just start fresh. I still didn't get an update for this anyway, I guess I need to get a separate ISO for it?

 

I think you are kinda wasting your time with this stuff. If you still wish to reformat then do this, download whatever Nvidia drivers you think were the most stable, then install Physx and the video driver only, uncheck anything else for now, no 3D stuff (unless you really need it?), GeForce Experience and so on.

 

Only install the absolute necessary. You can use GameSave Manager to backup all your savegames, it saved me some pain. If you have a PS3 controller stop using MotioninJoy, follow this guide instead.

http://pcgamingwiki.com/wiki/PS3_Controller

 

If things still don't work right, then revert back to a previous version of Windows 10 if you can. Realistically, I doubt you'll be able to solve these issues if they are being caused by the OS itself. You might find some workarounds but, things will always feel off anyway, might as well just save you some of your time.

 

I'm not saying you should give up, but I'm sure you'd rather be playing the games again as quickly as you can.

 

Oh and, do you know if anyone filed any bug reports, (similar to the issues you are having) on the Windows 10 bug tracker? Maybe someone figured out how to solve this already. Sorry, kinda sleepy.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

  • Found PCGamingWiki useful? Please consider making a Donation or visiting our Patreon.
  • Who's Online   0 Members, 0 Anonymous, 292 Guests (See full list)

    There are no registered users currently online

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Forum Statistics

    1,467
    Total Topics
    7,945
    Total Posts
×
×
  • Create New...