Jump to content

Welcome to the upgraded PCGamingWiki forums and files page. The current Wiki and Forum bridge is not functioning at the moment, therefore your Forum account currently has no password set. Please reset your Forum password via email check to generate a new password. If you have any issues please message Andytizer on Discord.

TerminatorOST

Ghost Recon: Future Soldier does not go fullscreen correctly

Recommended Posts

Well, I played this game successfully for several years now, and suddenly after recent reinstall it won't go fullscreen properly. Any resolution I choose (including my native 1920x1080) will result in black bars at the top and the bottom of the screen. I tried to edit default.cfg as it was listed in the wiki, removed saves, reinstalled game several times - no dice.
It's just this one particular game, which was working fine for years and suddenly it won't.
And I didn't change any hardware as well, everything is still the same.

Share this post


Link to post
Share on other sites

Was about to comment on resolution, as you have selected 1920x1080 and screenshots are 1600x900, but they are same 16:9 aspect ratio. And game adds black bars to anything other than 16:9 aspect ratio which seems to be what's happening to you for some reason. 

 

Though this wouldn't be first time I see game screwing up aspect ratio with some resolutions. I'm assuming your monitor is 1600x900, so have you simply tried to use your monitors native resolution? 

Share this post


Link to post
Share on other sites

1920x1080 is my monitor's native resolution.
Again, the game worked fine previously. I could set, for instance, 1366x768 or 1280x720 to set higher settings and stable FPS, and there would be no black bars. But now it's on all resolutions.
But it's just this particular game, every other game works like before.

Share this post


Link to post
Share on other sites

I've tried it, but the game can't even launch at windowed mode for some reason.

Update: deleted "default.cfg" and suddenly the game did launch at windowed mode. But when I press on "default settings", its black bars again.
At least the windowed mode is working now. Still better than a stretched image in fullscreen.

Share this post


Link to post
Share on other sites

..I wonder if the game isn't reading setting file from cloud, like Batman Arkham asylum steam GOTY (which made me mad).

try to delete config files, in offline mode and with no connection.

Share this post


Link to post
Share on other sites

Oh, right.

Sorry I'm running off ideas.

 

What if you toggle vsync, dx11 or use another resolution?

That was the first thing I did. I usually play at 1280x720 or 1366x768 to gain more FPS, but it won't work now too.

 

 

Since Windowed mode is working, perhaps you could try Borderless Windowed? Or are you getting black bars on Windowed mode as well?

No, windowed is without bars. Haven't tried borderless, to be honest, because I saw on wiki page that it's "impossible".

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Who's Online   2 Members, 0 Anonymous, 96 Guests (See full list)

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Forum Statistics

    1,139
    Total Topics
    6,540
    Total Posts
×