Jump to content
Sign in to follow this  
Nicereddy

Fixboxes unable to contain equal signs

Recommended Posts

Fixboxes default to {{1}} if you add an equal sign inside them. This causes problems when changing settings or files with equal signs in them.

 

For an example go to the Linux section of the Team Fortress 2 Article.

 

EDIT: I've also found that this also happens when inserting links ([http Text]) into fixboxes.

Share this post


Link to post
Share on other sites

To avoid this, specify the parameter number as shown in the Sample Article:

 

{{Fixbox|1=

 

This way equals signs are not misinterpreted as parameters. The Team Fortress 2 example you give did not use fixbox in the suggested manner, hence why problems occur when you include equals signs in the template content. I have fixed the page now. If you have problems like this with fixbox in the future, check to see whether it has the |1= part present.

 

This applies to all templates, e.g. if an availability link needs an equals sign simply specify numbered parameters for that use of the template (other uses in the availability list can omit the numbers as usual).

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Found PCGamingWiki useful? Please consider making a Donation or visiting our Patreon.
  • Who's Online   3 Members, 0 Anonymous, 374 Guests (See full list)

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Forum Statistics

    1,323
    Total Topics
    7,197
    Total Posts
×
×
  • Create New...